Results 1 to 4 of 4

Hybrid View

  1. #1
    RC Competitor
    Join Date
    Dec 2012
    Posts
    55

    QR-1 Rotor flies off!

    I have a rotor that will no longer stay on the QR 1. I push it down all the way then hold the QR 1 up to full speed for a 3 seconds and that blade will keep flying off.

    I am new to the QR-1 ... The blade otherwise looks fine... any good trick to use this blade again? (I replaced it with the matching spare but now I have no replace for "A" in black.

    Also is "A" in blue the same as "A" in black (other then colour)?

    Thanks,

    Joe

  2. #2
    RC Qualifier
    Join Date
    Feb 2012
    Location
    Virginia
    Posts
    403
    Yes the A in blue and the A in black are the same outside of color. All the color is for is so you know which way your are going.
    Slash 4x4 stock
    Slash 4x4 MMP 2400
    KB Fiesta

  3. #3
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,275
    I bought some blades for a HeliMaqx that are now doing that on my QR-1. The best fix is going to be replace the blade but until they are available I put a tiny and I do mean TINY dab of Shoe Goo on the very tip of the motor shaft then put the blade on . So far it seems to be working but I cant stress enough it has to be a tiny amount of Shoe Boo.
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  4. #4
    RC Competitor
    Join Date
    Dec 2012
    Posts
    55
    Ok thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •