Results 1 to 8 of 8
  1. #1
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    586

    LED Lights on bumper and light bar blinking?

    Had a quick question.

    My summit has been amazing out if the box. But I noticed right at the end when my Nimh packs were losing their juice, on hard acceleration in second gear only the lights on my bumper and light bar I added would go dim or off for a quick moment and then come right back on once the truck got up to speed. Is this normal?

    Is this a result because of the lower state of power in the packs and the heavy power draw accelerating in 2nd gear for this heavy beast of a truck? Any suggestions are welcome.

    Thanks

  2. #2
    RC Turnbuckle Jr. jamann's Avatar
    Join Date
    Sep 2009
    Location
    Victoria B.C Canada
    Posts
    5,061
    yes that is normal,Its a sign to change batts.
    You should never run the batts until the truck stops moving.
    very hard on the batts,premature death for them
    many have gone to lipo batteries for better run time dramaticly more consistent punch and power all the way through the pack.
    nimh start loosing punch as soon as you take them off the charger and fade much quicker under load.
    Mountains cant stop me
    they have tried

  3. #3
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    586
    Quote Originally Posted by jamann View Post
    yes that is normal,Its a sign to change batts.
    You should never run the batts until the truck stops moving.
    very hard on the batts,premature death for them
    many have gone to lipo batteries for better run time dramaticly more consistent punch and power all the way through the pack.
    nimh start loosing punch as soon as you take them off the charger and fade much quicker under load.
    Thanks for the quick response and the information.

    I hope to get some lipos here next week after pay day. I'm thankful my ESC on the summit is the one with the LVA.

  4. #4
    RC Turnbuckle Jr. jamann's Avatar
    Join Date
    Sep 2009
    Location
    Victoria B.C Canada
    Posts
    5,061
    Even if it wasn't we got ya covered there too low voltage alarms
    Make sure you have a charger capable of charging lipo.


    Sent using lipo power
    Mountains cant stop me
    they have tried

  5. #5
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    586
    Quote Originally Posted by jamann View Post
    Even if it wasn't we got ya covered there too low voltage alarms
    Make sure you have a charger capable of charging lipo.


    Sent using lipo power
    Will do on the lipo charger. That would be a shame to ruin a new lipo.

  6. #6
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Newcastle, Australia
    Posts
    945
    im guessing that would be because the motor is drawing all the power

  7. #7
    RC Turnbuckle Jr. jamann's Avatar
    Join Date
    Sep 2009
    Location
    Victoria B.C Canada
    Posts
    5,061
    The Nimh struggle to supply this monster.After partial discharge really start to struggle to supply the amps that are being demanded,so everything suffers even low draw led lights.Its 13 pounds or so.Its a hungry monster,feed it some lipo,find a hill and watch it eat...lol


    Sent using lipo power
    Mountains cant stop me
    they have tried

  8. #8
    RC poster
    Join Date
    Jan 2013
    Posts
    4
    Yup i am agree with above post. It is normal. This thread have remind me my honda reborn. I was don in matte black wrap and Red LED bumper lights. LED lights just look awesome.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •