Results 1 to 9 of 9
  1. #1
    RC poster
    Join Date
    Dec 2012
    Posts
    5

    Trouble shooting HELP

    Just got the Summit for Christmas. The red and green light continuously flash on the EVX 2. Can't find anything on this in the manual. Can someone help me?

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,959
    Sounds like it could be a servo issue. Do any of the servos feel warm to the touch? If so, unplug that servo from the receiver and see if the blinking issue goes away.
    Whatever it is I just said... I could be wrong.

  3. #3
    RC poster
    Join Date
    Dec 2012
    Posts
    5
    The EVX 2 easy set LED light blinks red/green continuously when you turn it on. The on/off control button will not turn the unit off once this starts, you have to unplug the batteries. None of the servos are hot. Also, the batteries arc when you plug them in.

  4. #4
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,959
    The EZ Set button should not be used to turn the unit off. It is recommended to unplug the batteries instead.
    Arcing is normal, mine do that too.

    I would open up the receiver box and unplug one servo at a time, just in case it is beyond the warming up stage and still causing issues.
    Whatever it is I just said... I could be wrong.

  5. #5
    RC Racer
    Join Date
    Nov 2012
    Location
    MN
    Posts
    138
    Quote Originally Posted by Sertell View Post
    Just got the Summit for Christmas. The red and green light continuously flash on the EVX 2. Can't find anything on this in the manual. Can someone help me?
    Mine did the exact same thing when I got it. I had to reprogram the transmitter to the factory defaults. I instructions are in the manual. It's worth a try.

  6. #6
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,959
    That is a simpler solution... hopefully that is it!
    It will get you out playing with your new RC a lot quicker...
    Whatever it is I just said... I could be wrong.

  7. #7
    RC poster
    Join Date
    Dec 2012
    Posts
    5
    Thanks to all. We tried all of your suggestions. Same results. I'm going to call Traxxas tomorrow. I hope they have a good support service! My 10 year old is really bummed. Hopefully we will get it working soon.

  8. #8
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,959
    Traxxas has excellent customer support. I am very confident that they will do all they can to get your Summit up and running as it should.
    Whatever it is I just said... I could be wrong.

  9. #9
    RC Racer
    Join Date
    Nov 2012
    Location
    MN
    Posts
    138
    Hope it's something simple and you can get it up and running in no time!

    Sent from your basement using Tapatalk2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •