Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Mar 2013
    Posts
    2

    Question Poor acceleration, poor top speed

    I am brand new to the RC world. Have a Stampede with about 7-8 tanks of gas burned. Was running perfectly with lots of power, good accelaration, etc. Now, the engine sounds to be revving up fine, but it takes nearly full throttle to get it to move on any kind of upward grade and the top speed is easily less than 1/2 normal, despite the engine revving to the moon. I can't see how it could be a fuel mixture thing, since we didn't change anything - it started suddenly while using it for about 5 minutes.
    I don't know if this is relevant or not, but my son ran it head on into a firm snowbank right before it started acting funny.

    Your help is appreciated.

  2. #2
    RC Champion
    Join Date
    Mar 2012
    Location
    Dawson creek bc
    Posts
    1,115
    Try righting up your slipper
    Clutch all the way then backing it off 1/4 turn. If its set any looser than that, it could cause the issues your talking about

    It's the nut that's in front of the spur gear



  3. #3
    RC poster
    Join Date
    Mar 2013
    Posts
    2
    Problem fixed. Thanks so much. My son is very grateful he truck is working again!

  4. #4
    RC Champion
    Join Date
    Mar 2012
    Location
    Dawson creek bc
    Posts
    1,115
    Your welcome. Stick around the forums, lots of great info

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •