Results 1 to 10 of 10
  1. #1
    RC poster
    Join Date
    Dec 2012
    Posts
    7

    Question Revo 3.3 Acting Up

    My revo 3.3 is acting very odd.
    Whenever I start it and drive it around it will go for about 5 seconds it will just stop and the remote won't work at all. Also whenever I put it in reverse I have to give it a little push backwards to actually go. Another thing-whenever I pick it up or flip it it floors it-is that normal?
    Everything on it is stock
    Please help me

  2. #2
    RC Champion
    Join Date
    Feb 2012
    Posts
    2,215
    Definitely sounds like a reciever problem. You've got the classic symptoms: No response, acts wild when flipped over...yeeeeeep. You're going to have to tear that reciever out and take a look.
    "I like rc cars"....."WHAT? YOU'RE KIDDING!"

  3. #3
    RC poster
    Join Date
    Dec 2012
    Posts
    7
    What would I be looking for? What are some common problems?
    I just completely switched to a new remote. This problem is still occuring.
    You know how when you start a revo with the controller off and there's just a red light? I'll be driving and that will happen and it will just not work.

    Thanks
    Last edited by fidlstks; 12-21-2012 at 07:55 PM.

  4. #4
    RC Champion
    Join Date
    Feb 2012
    Posts
    2,215
    Its your receiver, not your controller. You have to take the radio box cover off and inspect the reciever. Maybe cut wires?
    Also did you get the truck wet at all?
    "I like rc cars"....."WHAT? YOU'RE KIDDING!"

  5. #5
    RC poster
    Join Date
    Dec 2012
    Posts
    7
    I replaced the receiver with the controller.

  6. #6
    RC Champion
    Join Date
    Feb 2012
    Posts
    2,215
    Oh, okay. Then check all your wires for fraying or cuts.
    "I like rc cars"....."WHAT? YOU'RE KIDDING!"

  7. #7
    RC Champion
    Join Date
    Apr 2011
    Posts
    1,994
    The truck is causing interference. Check for metal on metal parts that could be rattling together.
    That's the first thing to do. When you said it will just stop did you mean the engine stops or the truck won't drive?
    The rear engine bearing may have gotten so bad it won't stay running and it also screws up the radio system.
    erbe emaxx 26maxx s27revo 18tmrevo XXL platinum

  8. #8
    RC poster
    Join Date
    Dec 2012
    Posts
    7
    The truck just won't drive.
    The function light is just red.

  9. #9
    RC Champion
    Join Date
    Apr 2011
    Posts
    1,994
    Something is causing it to go into failsafe mode, like a rattle or bad engine bearing.
    erbe emaxx 26maxx s27revo 18tmrevo XXL platinum

  10. #10
    RC Champion
    Join Date
    Mar 2009
    Posts
    1,876
    if you have an opti drive in your car.. thats your problem.. take it out...
    you know.. i never had a sig.. but i do now...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •