Results 1 to 2 of 2

Thread: servo question

Hybrid View

  1. #1
    RC poster
    Join Date
    Dec 2012
    Posts
    1

    servo question

    Hi all,
    I'm new to the forum and new to R/C. I got my first R/C the other day, the 1/16 summit VXL brushless.
    Today while running my truck I noticed when making a turn (can't remember whether it was right or left, but only one direction) it was making a clicking noise. I assume it was coming from the servo. is this normal, or is the servo stripping?
    Thanks,
    Brett

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,952
    It is pretty common for the servos to fail on this platform.
    Gear sets can be had for less than $5, but if it is new; a call to Traxxas should get you a free servo.

    If you want to replace it with something that will hold up better, there are a few inexpensive options....
    BlueBird 390
    HiTec 5085

    I have the BlueBird, so I can tell you how to set that up...

    BB 390 Set Up

    All stock hardware is used.
    NONE of the hardware included is needed!


    There are tab braces that do not allow the servo guard to sit flush.
    IT IS OPTIONAL TO REMOVE THEM.
    I have done this both ways without any adverse reactions.
    Here is a picture of the braces:

    (thanks goes to danielhr77 for the picture)
    The tab braces create a small gap between the chassis and the servo guard.

    Here is how it plugs in:



    You will also need to reverse the servo direction.
    These are the steps for LINK and TQi radios:

    Hold MENU for 3 seconds
    Green Blinks

    Press MENU
    2 Green Blinks

    Press SET
    Green Blinks

    Press SET
    Red Blinks

    Press SET
    8 Green Blinks

    Hold MENU
    Setup Complete
    Whatever it is I just said... I could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •