Results 1 to 2 of 2
  1. #1
    RC poster
    Join Date
    Dec 2012
    Posts
    1

    ESC problems - Velineon VXL 3m w/ 2 x 3S MaxAmps Green packs in parallel, not series

    Hello,

    We have a Summit with the Velineon VXL 3m ESC and stock brushless motor. It has been working great with MaxAmps Green (LiFePO4) batteries, 2 x 2S 6.6v 1050MaH in parallel. I upgraded to same chemistry/battery in the 2 x parallel configuration, but 3s which are 9.9v. This is way under the rated limit on the ESC. We burned out one ESC, so I figured it was just bad and returned it. Traxxas was really great about supporting us with it by the way. Never figured out why, and it ate the battery when it failed.

    Now the second one has failed.
    Everything stock (even the replaced parts we broke bashing....)

    Here are my questions:
    * Is anyone else having problems with this ESC using parallel batteries?

    * Anyone else can confirm Green 3S in a Summit or Revo VXL? (We have been using 2S for years and love them) Never had a problem in the Revo.

    * Any thoughts on replacing the Velineon again - or just upgrading? I like the custom fit and features of the ESC, but can't have it blowing up all the time. My son is building a kit (exo terra buggy) and we got a Mamba Max Pro that looks beefy and great features, though he hasn't run it yet. I haven't researched replacing it yet, but maybe there is a common recommend controller people like? Mostly bashing/jumping off roads driving, not too concerned about top speed.

    * I've some threads about servos causing trouble, but no sign of any servo trouble. Works fine, but could it be realated?

    Anyway, if anyone has any experience or thoughts, it would be appreciated. First post, but I've found many answers here, so a shout out to everyone for a great forum!

    Bob

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    I have seen a "working" servo cause all sorts of electrical issues... it could be the issue, but I am hesitant to say it is the issue. The 3M is not known for its strength in these RC's... not that it is a bad ESC, but ever since I switched to a ********* 60 amp ESC, I have not once overheated or had any issues what-so-ever... other than when I was geared 28/45 on 3S lol. I am not sure what the deal is with the ESC, but it does not seem to like anything over 2S voltage, or 8.4v.

    My suggestion is to upgrade.

    Here is the thread on the ESC I am now using:
    http://traxxas.com/forums/showthread...w+installation

    There are some waterproof options that are coming out now... but I have not done any research to point you in the right direction on those.
    Whatever it is I just said... I could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •