Results 1 to 10 of 10
  1. #1
    RC Enthusiast
    Join Date
    Nov 2012
    Posts
    33

    Cooling Head does this look right?

    I bought a used revo and having a problem getting to to stay running. It keeps fouling plugs out and just doesnt want to stay running. I took the cooling head off and there are small scratches in it not sure if this motor is toast? When I get it to run it runs ok but just wont run for long then fouls the plugs out. I got it cheap so buy a new motor wont bother me much but i hope this is normal wear and tear. Below is the pick of the bottom of the cooling head I have not taken the rest of the motor apart yet.

    Thanks,
    Joe


  2. #2
    RC Champion
    Join Date
    Feb 2012
    Posts
    2,215
    That is not good. Sure sign that dirt, and a lot of it, has gotten into the engine. This could definitely be the reason why you're fouling plugs. Take a look at the top of the piston. It more than likely looks the same way. If it does then you could either try rebuilding the engine with a new cooling head piston sleeve and bearings or buy a new one.

    EDIT: Also just noticed in the pic that around the edge looks like theres metal shavings.
    Not good either.
    "I like rc cars"....."WHAT? YOU'RE KIDDING!"

  3. #3
    RC Enthusiast
    Join Date
    Jul 2012
    Location
    Canada,Qc
    Posts
    29
    Yeah metal shavings is never a good thing ...

  4. #4
    RC Enthusiast
    Join Date
    Nov 2012
    Posts
    33
    here is a close up of the top of the piston i guess this doesnt look so good either. From a foot away it didnt look bad but close up not so good i guess.


  5. #5
    RC Turnbuckle Jr. humayrayakongkinaon's Avatar
    Join Date
    May 2011
    Location
    Long Beach, California
    Posts
    6,589
    your engine running way too lean causing the piston to chip and maybe with few more run you'll experience blown engine
    | Rally GT8 Powered By CC | BackSl4sh Roadrunner |

  6. #6
    RC Qualifier
    Join Date
    Aug 2004
    Location
    Yankton, SD (south of ND)
    Posts
    268
    Thats a pretty good sign it was run lean, causing the plug to get hot and the coil to fall out and get embedded into the piston. Id replace it before to many pieces make their way in the bearings.
    My Revo: OS .18TM, 16/38 gearing, wide ratio 2nd speed, futaba throttle servo, new era shock ends, FOC, Pullstart, P3 rockers, Aluminum Pushrods, Plymouth HEMI Cuda' Shell, LT springs, GTR shocks, did i mention its got a HEMI!! And a wicked fast TRX-1!! (It'll smoke the Team Associated's B4)

  7. #7
    RC Qualifier
    Join Date
    Jun 2012
    Location
    Palisade Colorado
    Posts
    511
    Wow I say it sucked in some dirt and it was running to lean, wow!! Here is my suggestion: don't even bother about rebuilding it because its had dirt run through it I say just but a new engine so you don't have to worry about cleaning it really good and you know it's new just thoughts

  8. #8
    RC Competitor
    Join Date
    Aug 2011
    Location
    Newfoundland, Canada
    Posts
    87
    Yeah...go buy a new engine and be done with it...

  9. #9
    RC Enthusiast
    Join Date
    Nov 2012
    Posts
    33
    Thanks everyone I went and did the trade in program at my LHS.I was able to trade in two 3.3's and one .15 for a 2.5r so I'm all set for motors now. Me and a friend went halves on a huge lot of nitro's. The only one that had an issue out of the 7 we got was the revo. We got 7 nitro's for less than a 100 a piece and enough spare parts to build another revo and tmaxx. So I will be busy for a while. I already had a new revo and a emmax after I am done with these I will have 3 revo's, a tmaxxx, Slayer 3.3, and two rustlers and two smaller losi electrics.

  10. #10
    RC Champion
    Join Date
    Mar 2009
    Posts
    1,873
    its your bearing.... little pieces chipped off.. could be from running lean or just faulty bearing... had a few in my time... either way new engine and toss this one.. keep the carb and back plate... they are good spares to have
    you know.. i never had a sig.. but i do now...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •