Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    Nov 2012
    Posts
    12

    Malfunction steering servo question, Need Help

    My son wrecked my Summit the other day, broke both steering servos, replaced them with new ones, they worked fine for about 3 minutes then they started acting up , really weak response and the headlights flash and lose power everytime you try to turn, the batteries are fully charged. Any idea how to fix? Thanks!

  2. #2
    RC Qualifier
    Join Date
    Jul 2012
    Location
    the middle of nowhere
    Posts
    419
    Sounds like you might have gotten a bad replacement servo.

    Unplug them one at a time to help figure out if one is bad. On bad servo can affect a lot.

    Unplug one check steering, plug back in unplug the other check steering.

    Sent from my iPhone using autocorrect

  3. #3
    RC poster
    Join Date
    Nov 2012
    Posts
    12
    Thanks, any other thoughts if this doesn't work? I've left the house and won't be home till tonight to check it out, it's 2 hours to the nearest parts house and I want to pick up anything that may be possibly broke so I don't have to come back. Thanks!

  4. #4
    RC Qualifier
    Join Date
    Aug 2010
    Location
    Port orange, Florida
    Posts
    568
    Instead of buying more replacement servos get a good single servo and you shouldn't have the problem anymore, Hitec makes some good servos they cost around 100 dollars but its usually a one time replacement I have servos from 5 years ago that I still am using, good luck and have some fun


    Sent from my iPhone 5

  5. #5
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Los Angeles / South Bay
    Posts
    439
    Not sure how your servos broke but if it's stripped gears the servos are still good, just need to replace the gears, parts bag TRA2072.

  6. #6
    RC poster
    Join Date
    Nov 2012
    Posts
    12
    Awesome, glad I saved the old servos, they broke when it hit a tree, any idea were I can buy the single servo?

  7. #7
    RC poster
    Join Date
    Nov 2012
    Posts
    12
    Could it be a malfunction in the brain that controls the steering, starts blinking then the truck loses all function .

  8. #8
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Los Angeles / South Bay
    Posts
    439
    Dunno about your servo problems and I'm not a single servo user... however as for your new servos I would check for binding in your steering system ie unlink the servos at the servo arm and make sure all the linkages, knuckles, pillow balls are free and your wheels steer without any effort. Any binding will wear down the servos and eventually fail, the dim headlights could be excessive current draw. IMO it's normal for the lights to flash occasionally but I did have my pivot caps overtightened resulting in binding and messed up my gears. Do the same for the rears too, it helps with suspension travel.

  9. #9
    RC Turnbuckle Jr. jamann's Avatar
    Join Date
    Sep 2009
    Location
    Victoria B.C Canada
    Posts
    4,982
    9 times out of 10 its a servo.they can make the evx do all kinds of odd things
    From all the servos going crazy to the truck just shutting down.


    Sent using lipo power
    Mountains cant stop me
    they have tried

  10. #10
    RC Qualifier
    Join Date
    Jul 2012
    Location
    the middle of nowhere
    Posts
    419
    Quote Originally Posted by jamann View Post
    9 times out of 10 its a servo.they can make the evx do all kinds of odd things
    From all the servos going crazy to the truck just shutting down.


    Sent using lipo power
    I'm with ya, I'd start with the servos


    Sent from my iPhone using autocorrect

  11. #11
    RC poster
    Join Date
    Nov 2012
    Posts
    12
    Went ahead and bought a high tech single servo with metal gears, should fix my issue, I'll post picks and a update tomorrow!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •