Results 1 to 4 of 4
  1. #1
    RC Competitor
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    50

    Receiver not responding?

    How do you determine if its the transmitter or receiver? The receiver light it not turning on neither green or red. I tried using a battery pack and the AA pack that comes with it when you first buy. Neither is turning the light on the receiver, could there be another issue or is the receiver dead?

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the wet stuff on the hot stuff
    Posts
    9,842
    Unplug the servos and verify there is power at the plug of the battery pack by using a multi-meter. Bypass the switch and plug directly into the receiver. It should light up red until the transmitter is on then green.
    The Super Derecho

  3. #3
    RC Competitor
    Join Date
    Jan 2012
    Location
    New Jersey
    Posts
    50
    Right on the money, I unplugged both servos and the switch. I checked the battery for power and it had full power then I plugged it in directly. Light was red until I turned the transmitter on and it went green, I turned the transmitter off and it blinked red. So I am assuming by that the switch went bad?

    Thanks

  4. #4
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the wet stuff on the hot stuff
    Posts
    9,842
    Possible. Plug one servo in at a time and see if they work. If so then the switch may be to blame.
    The Super Derecho

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •