Results 1 to 12 of 12
  1. #1
    RC Racer
    Join Date
    Apr 2012
    Posts
    111

    CC Blower, not working

    Just added the CC Blower fan, but it's not working. Is it supposed to run all the time? Plugged in to chanel 5/batt.

  2. #2
    RC Qualifier
    Join Date
    Apr 2011
    Location
    Frisco, TX
    Posts
    389
    Yeah it's supposed to run all the time. Is it new? Did you try switching the way it's plugged in?

  3. #3
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,862
    the brown or darkest wire should go to the outer edge of the Rx...
    Would you go flip my truck back over??

  4. #4
    RC Qualifier
    Join Date
    Apr 2009
    Posts
    380
    Sounds like you have it plugged in backwards. The Black wire should be on the outer edge of the receiver and the open pin goes inwards.

  5. #5
    RC Racer
    Join Date
    Apr 2012
    Posts
    111
    I have to check, did not think it fitted both ways. Thanks

  6. #6
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    Always possible that its defective

  7. #7
    RC Racer
    Join Date
    Sep 2012
    Location
    Kentucky
    Posts
    101
    Do they take any noticeable run time away?

  8. #8
    RC Champion
    Join Date
    Aug 2012
    Location
    Central NJ
    Posts
    1,245
    No, they dont have an effect on run time. The current draw on those is so miniscule you could run the fan probably for a week or more on the battery.

  9. #9
    RC Qualifier
    Join Date
    Jun 2012
    Location
    Norway
    Posts
    290
    Which blower are you using? I see there are 3 different models on AMain: CSE011-0004-00, CSE011-0014-00 and CSE011-0019-00.

  10. #10
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,862
    Guess I will ask why do you need the fan?? Is the motor running that hot you need a fan??

    A temp gun is kind of a must have.....

    Hot motor + cool esc = under geared.
    Cool motor + hot esc = over geared
    Everything warm just right..

    Motor ~ 180/190*F (82/88*C) maximum, ideally 140/160*F (60/71*C), temps can be 10*F higher inside the motor
    ESC ~ pretty much same temps / Fan comes on @ 150*F (65*C)
    Lipo's ~ 140*F (60*C) max, ideally 100/120*F (38/49*C).........

    Besure to check sizing before you buy any batteries...
    Would you go flip my truck back over??

  11. #11
    RC Qualifier
    Join Date
    Apr 2011
    Location
    Frisco, TX
    Posts
    389
    87 GN-

    Everytime the CC blower fan comes up, you post the same thing. It makes me laugh every time!

    Although I agree that proper gearing is the key to manageable temps, I still run a fan on my motor. I guess it's just the peace of mind I get knowing my motor's gonna run 10* cooler! Haha. The hottest I've ever seen my motor is 137* after lots of speed running and hard bashing on 6s w/ 40 series trenchers. So really, the fan is just taking up space.

  12. #12
    RC Racer
    Join Date
    Apr 2012
    Posts
    111
    why i need the fan? well, don't need it but i like the way my e-revo is geared rigth now (18/58) but motor gets a bit hotter than i like it to sometimes. Everything warm as you say is good but cooler is even better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •