Results 1 to 7 of 7
  1. #1
    RC Competitor
    Join Date
    May 2011
    Location
    Aztec, NM
    Posts
    56

    slayer wont start please help!!!!

    I am brand new to nitro rc. I bought a used slayer off ebay. Got it in, bought 20% nitro fuel, got excited, try to start it and it wont start. Has ez start system. Glow plug light lights up as does engine light. Cranks over but wont start. Though i flooded it so i followed procedure to un flood it. Removed glow plug, cranked it over and spit out excess nitro, installed plug disconnected ez start wire and pressed button to heat glow plug to burn of excess. Hooked up wire and still wont start. So i put carb back to factory settings and still no luck. Please please help

  2. #2
    RC Champion
    Join Date
    Feb 2012
    Posts
    2,215
    Try replacing the glow plug. Usually thats the first thing you should do with a used engine.
    "I like rc cars"....."WHAT? YOU'RE KIDDING!"

  3. #3
    RC Competitor
    Join Date
    May 2011
    Location
    Aztec, NM
    Posts
    56
    Yep that solved it. Had to drive an hour to nearest HS but got er done. But now i encounter a different problem. It seems like it doesnt wanna run at WOT. And if im just cruising along and punch it it dies but i can kind of ease into it and it revs up but once I hit WOT it cuts out. Any ideas?

  4. #4
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,363
    Yep that solved it. Had to drive an hour to nearest HS but got er done. But now i encounter a different problem. It seems like it doesnt wanna run at WOT. And if im just cruising along and punch it it dies but i can kind of ease into it and it revs up but once I hit WOT it cuts out. Any ideas?
    That sounds like your hsn is too lean, causing your engine to 'cut out' or "shudder" at speed. Try riching the hsn a little. Hope this helps!
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  5. #5
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Planet Vegeta
    Posts
    651
    Quote Originally Posted by Wolfslash16 View Post
    That sounds like your hsn is too lean, causing your engine to 'cut out' or "shudder" at speed. Try riching the hsn a little. Hope this helps!
    just like he said, your engine isnt getting enough fuel in the fuel/air mix
    All I need now is to set a new lap record.

  6. #6
    RC Competitor
    Join Date
    May 2011
    Location
    Aztec, NM
    Posts
    56
    Thanks for your help. Still havent got it figured out but im tryin. Now if i put revo tires on the slayer without changing gearing could that be causing problems as well?

  7. #7
    RC Competitor
    Join Date
    Oct 2012
    Location
    Colorado
    Posts
    98
    yes, you could have over heating issues
    I'm crazy, no really I am.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •