Results 1 to 7 of 7
  1. #1
    RC Qualifier
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    592

    Suspension setup

    I noticed in driving my Summit today for the first time that the suspension travel insane!! But I also noticed that the rear skid plate was slapping the ground quite a bit on high speed runs down my driveway and off the curb. Any suspension tuning I can do to help stiffen up the suspension just a bit?

    Move the suspension link to the outside hole? Increase ride height? All the above? Thicker shock oil (if shock oil any suggestions? something else I'm missing?

    I dont want to loose my suspension articulation for crawling but want to help keep the butt from dragging just a little less then it is right now.

    THanks

  2. #2
    RC Enthusiast
    Join Date
    Aug 2012
    Posts
    47
    Your front springs are alittle stiffer than the back. So you can move your back springs to the front and front to the back. Then you might want to get some heavier weight oil. I would start out at 50 weight.

  3. #3
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Chehalis, Wa
    Posts
    436
    I'm running Dbl orange springs front and rear and 100wt oil and the highest setting (inside hole) on the links and no preload . I love the no sag and no bottom out but for crawling the 30 degree temps kill the 100wt oil on suspension travel. I'm going to switch up oil for winter and summer play.

    Oh and my summit a arms sit flat with the chassis. I want it low as possible with the most amount of suspension travel. I'm hopping that to get another set of shocks with Dbl orange springs and 30wt oil and see how that does in cold temps.
    _______^_
    /______l__\____
    l_l O l_____l O l

  4. #4
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Chehalis, Wa
    Posts
    436
    I was just reading threw my manual and it said stock weight for the shocks is 50wt.
    _______^_
    /______l__\____
    l_l O l_____l O l

  5. #5
    RC Enthusiast
    Join Date
    Aug 2012
    Posts
    47
    Yeah it does say 50 I was thinking it was 30wt. Thanks for correcting me. I have purple with 50wt.

  6. #6
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Chehalis, Wa
    Posts
    436
    Quote Originally Posted by rcsickness1 View Post
    Yeah it does say 50 I was thinking it was 30wt. Thanks for correcting me. I have purple with 50wt.
    How do you like your setup?
    _______^_
    /______l__\____
    l_l O l_____l O l

  7. #7
    RC Enthusiast
    Join Date
    Aug 2012
    Posts
    47
    I like bashing more than crawling so it works out ok for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •