Results 1 to 13 of 13
  1. #1
    RC Racer
    Join Date
    Nov 2007
    Location
    KC Missouri
    Posts
    132

    Traxxas balance plugs and VXL issue

    I've searched and can't seem to find the answer that I'm looking for. I have a merv and a stampede that I am trying to get some new lipos for. Mine sat around my garage for the last two years ... Got a little busy to say the least. I have a hyperion charger but can't remember the kind of balancer plug that I have. I got it so it would take True RC packs. Just wondering if I'm good with my current balancer to get Traxxas batts or of I need to make a switch?

    Also on the merv I'm getting the blinking green light that is intended to indicate that my throttle trim is off. I've adjusted and re-adjusted but no luck. Is this possibly because my lipos look like fat girls in spandex? Swollen if you will. I know that they're dead but I wanted to give em a whirl anyway. Guess they're "too" dead?
    Last edited by I Break Parts; 12-03-2012 at 10:52 AM.
    Full FLM pede w/VXL power.

  2. #2
    RC Qualifier
    Join Date
    Jul 2012
    Location
    Baltimore, Maryland
    Posts
    426
    Way too dead, please recycle, we all want you to have your home for the holidays.
    BB MERV/T8 Rusty/OS21REVO
    Drive it like its Hot

  3. #3
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,703
    Quote Originally Posted by Mrmerv76 View Post
    Way too dead, please recycle, we all want you to have your home for the holidays.
    Too true! Nobody should have to spend the holidays in a burn unit...or a morgue.

    There are four taps in general use: Align (JST-XH), Kokam (JST-XE), Thunder Power/Flight Power, and Hyperion/Polyquest.
    TrueRC packs seem to use Hyperion balance taps. Traxxas packs use Align (JST-XH) balance taps.
    Alt-248 on the number pad =

  4. #4
    RC Turnbuckle Jr. Petertje60's Avatar
    Join Date
    Jan 2011
    Location
    Rotterdam, Netherlands
    Posts
    7,312
    Another +1. Break parts if you like, but never take any risk with swollen Lipos.
    Nobody is born with experience

  5. #5
    RC Racer
    Join Date
    Nov 2007
    Location
    KC Missouri
    Posts
    132
    Thanks for the warnings guys. I wasn't planning on using them to any extent just for a quick second. Thanks ksb51rl, that is exactly the answer I was looking for concerning the plugs.

    As far as the blinking light on the VXL is concerned ... probably the beyond dead lipos then?
    Full FLM pede w/VXL power.

  6. #6
    RC Turnbuckle Jr. Petertje60's Avatar
    Join Date
    Jan 2011
    Location
    Rotterdam, Netherlands
    Posts
    7,312
    Quote Originally Posted by I Break Parts View Post
    As far as the blinking light on the VXL is concerned ... probably the beyond dead lipos then?
    Correct. Most probably that is the reason.
    Nobody is born with experience

  7. #7
    RC Racer
    Join Date
    Nov 2007
    Location
    KC Missouri
    Posts
    132
    thanks much gang
    Full FLM pede w/VXL power.

  8. #8
    RC Racer
    Join Date
    Nov 2007
    Location
    KC Missouri
    Posts
    132
    So, the light stopped blinking but now its solid red and extremely faint. Barely on even. Also, it is getting crazy hot on the bottom on the side that motor wires are coming out of. No servo action and no throttle. Have my fears been realized and my ESC fried? I've never ran anything higher than 2s in it. It never overheated before. This is strange. Thanks for any help or advice in advance.

    If its fried I guess, big block here I come.
    Full FLM pede w/VXL power.

  9. #9
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    I have heard of ESC's going dead from sitting...
    Since it is probably the culprit, unless it is the servo as stated in my other post, you are not out anything if the following does not work:

    I once had funky ESC issues... an electrical engineer friend of mine suggested feeding 6v of power through the servo wires attached to the ESC. I am not sure what it did, but afterwards, the ESC worked fine.
    Whatever it is I just said... I could be wrong.

  10. #10
    RC Racer
    Join Date
    Nov 2007
    Location
    KC Missouri
    Posts
    132
    I am not sure to how to even go about that... Worth a try if I can figure it out though.
    Full FLM pede w/VXL power.

  11. #11
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    I used an old BEC battery holder and a chunk of wire to go from the holder to the servo wire connector.

    Whatever it is I just said... I could be wrong.

  12. #12
    RC Racer
    Join Date
    Nov 2007
    Location
    KC Missouri
    Posts
    132
    I might have one of those laying around. I'll have to check. Excuse my blatant ignorance but 4 AAs = 6v then?
    Full FLM pede w/VXL power.

  13. #13
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    Roughly, yes.

    1.5v each x 4 = 6
    Whatever it is I just said... I could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •