Results 1 to 11 of 11
  1. #1
    RC Racer
    Join Date
    Oct 2012
    Location
    Salta, Argentina
    Posts
    110

    problem out of the box in my new revo

    hello guys, I bought a revo few days ago. When it arrives I put a pair of 3s 5000mah 11.1v, and start it, it was fine until I hear a strange noise caming out of it, I stop it running, and took it to my house, then start ir over, elevate the model on a block, pull the throttle, and after 10 seconds it started making sparks inside the mamba monster esc, and then smoke come out of it. I turned it off as soon I could
    What happened????

  2. #2
    RC Turnbuckle Jr. vxlrocket's Avatar
    Join Date
    Dec 2007
    Location
    Manassas, Va
    Posts
    6,623
    it sounds like you blew your esc. Call castle creations www.castlecreations.com and tell them what happend. It's still under warranty so it ought to be covered and free to replace.
    ERBE, 8ight, 8ight-t, b4,b44, scte, slash 4x4

  3. #3
    RC Qualifier
    Join Date
    May 2012
    Location
    Arkansas
    Posts
    335
    Yeah what rocket said. Best of luck to you.
    ERBE, MERV BB

  4. #4
    RC Turnbuckle Jr. MITCH316's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    3,257
    That's bad luck mate...I have read about a few MMM ESC's doing this this month . I have heard that castle have a great warranty service.
    Rock n Rolla !

  5. #5
    RC Champion
    Join Date
    Aug 2012
    Location
    Central NJ
    Posts
    1,245
    They must have had a bad lot go through although Ive had this happen on a sidewinder ESC. Ran fine several times then one time I plugged in the battery and switched it on and the firworks commenced. Shipped it off to castle for warranty service and they denied it saying it had gotten wet. That ESC was never anywhere near water let alone in it. I think sometimes its all dependant on what tech gets the work order and how they happen to be feeling that day.

  6. #6
    RC Qualifier
    Join Date
    May 2012
    Location
    Arkansas
    Posts
    335
    Quote Originally Posted by JustinThyme View Post
    They must have had a bad lot go through although Ive had this happen on a sidewinder ESC. Ran fine several times then one time I plugged in the battery and switched it on and the firworks commenced. Shipped it off to castle for warranty service and they denied it saying it had gotten wet. That ESC was never anywhere near water let alone in it. I think sometimes its all dependant on what tech gets the work order and how they happen to be feeling that day.
    If there was a "like button" for this comment I would click it...
    ERBE, MERV BB

  7. #7
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,580
    I have never bought into a BAD LOT or BAD RUN............
    Not saying there haven't been some ESC that just went up in smoke...

    OP is this a new or used Revo.........?? What happend not sure..... You didn't run it thru water...??
    Would you go flip my truck back over??

  8. #8
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,825
    thats what i'm thinking 87GN that it might have hit water but sometimes esc's do go up for some strange reason. Also if people dont change gearing out when running 6s running it on stock gearing would kill the esc before the motor thats what ive seen.
    DEU 8:18 ESV

  9. #9
    RC Racer
    Join Date
    Oct 2012
    Location
    Salta, Argentina
    Posts
    110
    It didnt hit water and is a brand new revo, first run and happened that. Not even 20 minutes and then the fireworks start.

  10. #10
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,580
    good point....... gearing...........

    how were the temps...?? of the ESC.....


    A temp gun is kind of a must have.....

    Hot motor + cool esc = under geared.
    Cool motor + hot esc = over geared
    Everything warm just right..

    Motor ~ 180/190*F (82/88*C) maximum, ideally 140/160*F (60/71*C), temps can be 10*F higher inside the motor
    ESC ~ pretty much same temps / Fan comes on @ 150*F (65*C)
    Lipo's ~ 140*F (60*C) max, ideally 100/120*F (38/49*C).........


    what is the C rating of the batts..??

    ( mah x c rating / 1000 = amps)

    The more amps the better / minimun of 120 amps.

    The ESC will only draw the amount of amps it needs.
    Would you go flip my truck back over??

  11. #11
    RC Racer
    Join Date
    Oct 2012
    Location
    Salta, Argentina
    Posts
    110
    Neither the Esc or the motor were not hot because I turned it off a time before turning it on again (15 minutes perhaps).
    It has the stock gear all stock because it was it first run. And the battery are two 3s 11.1v 5000mah 25C

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •