Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    Dec 2012
    Posts
    19

    E-Maxx Brushless Not Working...

    Hey folks,

    I am wondering why my E-maxx Brushless isn't working properly, I have the 7 Cell Ni-MH version, I put it on, and then I press on the throttle and for some reason it keeps cutting out the power... The light on the receiver goes from Green to Red when the power is cut to the motor.

    can ANYONE help? I am really disappointed in Traxxas on this one, how can they say "Ready to race out of the box" when there isn't a charger included, and defective out of the box...

    I got this 2 days ago and I am still struggling to get this working properly.

  2. #2
    RC Qualifier
    Join Date
    Jan 2009
    Location
    MI
    Posts
    723
    First, here is a bad news, even though it comes with NiMH batts(now there is 3908L version that comes with Lipo's but this is not your case), the stock batteries can not handle well the MMM ESC / Motor combo. It will work for some time but not as it should. So you will need Lipo's to get the most of your truck.

    With that said, I would start looking if your battery is fully charged and checking if the Lipo cut off in the ESC is off?
    Not enough space here

  3. #3
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,133
    Quote Originally Posted by fvj View Post
    ...With that said, I would start looking if your battery is fully charged and checking if the Lipo cut off in the ESC is off?
    If the LED is green at rest, as stated, then the Low Voltage Detection (LVD) is enabled and should be disabled to run NiMH packs. Please do that and report back.
    Alt-241 on the number pad =

  4. #4
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,567
    third link will help setup....LVC

    AOD's Links EMaxx

    Emaxx 101:
    EMAXX FAQ

    Lipo, LVC, Brushless & Battery charger/charging guides & purchasing links:
    TUTORIALS

    Refer to this to setup the Mamba Monster ( MMM ) esc for maximum performance:
    CASTLE LINK GUIDE


    Refer to this to find parts, upgrades, batts & chargers etc:
    USEFUL LINKS


    And direct from CastleCreations ( the esc manufacturers ):
    MMM FAQ

    Driver's ED Manual

    LED warning light meanings

    EMAXX 3906 UPGRADE GUIDE & LOW BUDGET BRUSHLESS OPTIONS
    Would you go flip my truck back over??

  5. #5
    RC poster
    Join Date
    Dec 2012
    Posts
    19
    Quote Originally Posted by 87 GN View Post
    third link will help setup....LVC

    Refer to this to setup the Mamba Monster ( MMM ) esc for maximum performance:
    CASTLE LINK GUIDE
    Ok, but was the castle link adapter supposed to be included with the #3908? I do not seem to have it...

  6. #6
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,567
    not included.......

    or you can get a field card, does not have all the options for set up.....tho

    http://www.ebay.com/sch/i.html?_saca...le+Link&_frs=1
    Would you go flip my truck back over??

  7. #7
    RC poster
    Join Date
    Dec 2012
    Posts
    19
    Quote Originally Posted by 87 GN View Post
    not included.......
    Seems like I will have to do the third trip to the hobby shop in 3 days, $20.00 each time, this "hobby" is getting expensive...

    But wait, let me try to understand, the e-Maxx brushless with Ni-MH is ready to race, but doesn't have a charger, and is setup for Li-Po in the controller, but it's been sold as Ni-Mh, but if you want to make it work with Ni-Mh you must configure it using the castle link, which is, not included... How much is the "3908" really ready to race? I would of bought the 3908L(if the hobby shop would of had it in stock) which would of worked perfectly for me as I do have Li-Po charger and the configurations would of been the correct ones, but it seems on the 3908 they are failing by a long shot to make it "Ready to race" out of the box.

  8. #8
    RC poster
    Join Date
    Dec 2012
    Posts
    19
    Thank you all for your help, it was the LVC that was set to "Auto Li-Po" which was like 12v~, I just picked up the Castle Link and it works perfect now, time for me to get a 6S .

  9. #9
    RC Turnbuckle Jr. MITCH316's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    3,257
    Glad to hear its sorted mate...2/3s; that's my style...enjoy .
    Rock n Rolla !

  10. #10
    RC Qualifier
    Join Date
    Jun 2011
    Location
    North-West Ohio
    Posts
    945
    Quote Originally Posted by SlyCayer View Post
    this "hobby" is getting expensive...

    .
    It only gets worse...
    Never trust a fart.

  11. #11
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,567
    Quote Originally Posted by SlyCayer View Post
    time for me to get a 6S .
    Quote Originally Posted by SlyCayer View Post
    is getting expensive..
    it will get very ^ with 2/3s......
    Would you go flip my truck back over??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •