Results 1 to 13 of 13
  1. #1
    RC Enthusiast
    Join Date
    Nov 2012
    Posts
    33

    Rustler vxl 11.1 lipo issue

    Hello I have a Traxxas Rustler VXL, and I got a Traxxas 11.1v lipo 5000mah and after I charged the battery and put it in the truck it ran for about 5 minutes and then i lost 50% power and the red light on the esc began blinking.I know the battery is fully charged and I have the fan that goes on the esc.The hobbyshop told me that the battery may be damaged so I figured I would buy another battery which is the same 11.1 Lipo Just in case, and it does the same thing. It does it in race mode and in sport mode however if i use my venom 7.4v lipo It does not have any issues it only does is it with the 11.1v and it does it regardless if I run it at high speeds or if I hardly putt it around the yard. I have no idea what to do to fix the problem other than turn off the lipo protection mode on the esc and that's probley not a good move so...any suggestions would be helpful.
    Thank you

  2. #2
    RC Champion
    Join Date
    Mar 2011
    Location
    Zeeland Michigan
    Posts
    1,193
    I would call traxxas support , Mind does it every so often i just unplug it and re-plug it and thing are find after that .
    1 Rusty VXL

  3. #3
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,100
    Sounds like the ESC is suffering from a premature LVC cut off . If it is new I would call Traxxas and see about getting it replaced. If it is out of warranty I would consider turning off the LVC and using an external low voltage alarm. You can pick up the alarms very cheap on ebay.
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  4. #4
    RC Champion
    Join Date
    Nov 2012
    Location
    Nashville, TN
    Posts
    1,752
    Dad's right. Mine does this too, but not too bad. I just have to power-off and back on.

    An alternative would be to get a separate low voltage alarm that plugs into the balance port on the battery. It'll sound continuously when the voltage drops low. It'd probably cost the same amount as shipping your esc to traxxas. Also, if you ship that esc, you may be waiting a while to get it back.

  5. #5
    RC Enthusiast
    Join Date
    Jul 2012
    Posts
    32
    Quote Originally Posted by Dadx2mj View Post
    If it is out of warranty I would consider turning off the LVC and using an external low voltage alarm. You can pick up the alarms very cheap on ebay.
    I got one off of tower hobbies for around 9 bucks. It's a venom one and it works great. It has a digital readout that tells you the entire voltage of the pack and the voltage of each cell. It also has a very loud alarm for when it gets to whatever setting you have. You can choose from as low as 2.7 (don't quote me) volts per cell to as high as 3.8 volts per cell before the alarm sounds. It has worked really well for me so far. Here is the link http://www3.towerhobbies.com/cgi-bin...&I=LXBVDG&P=ML

  6. #6
    RC Enthusiast
    Join Date
    Nov 2012
    Posts
    33
    Okay well Ill be picking up one of the alarms I dont really want to wait on traxxas ill just have to unplug and reconnect the battery until I get the alarm, Its annoying but i can put up with it. thank you guys for your responses it is appreciated.

  7. #7
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Snow Belt, Ohio
    Posts
    372
    Maybe you didn't charge it at 3 cell? My charger you have to change it from 2s to 3s...

  8. #8
    RC Enthusiast
    Join Date
    Nov 2012
    Posts
    33
    I dunno I have a dynamite charger i just plug it in and put it on 5a

  9. #9
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Snow Belt, Ohio
    Posts
    372
    Quote Originally Posted by Attila2984 View Post
    I dunno I have a dynamite charger i just plug it in and put it on 5a
    Charger is most likely not your issue then.

  10. #10
    RC poster
    Join Date
    Nov 2012
    Posts
    6
    Hallo, sorry for late respond.
    I'm new on this forum.
    Looks likje you are overheating the engineering and of esc.
    If THE esc overheats it runs at 50%.
    And if he won't cool down he shuts of completely.
    I think it's afrond the 200f
    Hoop helping ( sorry for my writing, my english is not so good. I'm from belgium)

  11. #11
    RC Turnbuckle Jr.
    Join Date
    May 2011
    Location
    Fraser Valley, BC Canada
    Posts
    3,137
    Look on eBay for a LVA. You can get ones for about 3 bucks that work really well and are super easy to use. Also has a digital display.
    I don't have shelf queens, I have bash kings!

  12. #12
    RC Competitor
    Join Date
    Jan 2011
    Location
    Southeast Missouri
    Posts
    92
    Does that battery fit okay in your truck. I have one ordered.
    No Honey, I have had this one for a long time....

  13. #13
    RC Enthusiast
    Join Date
    Nov 2012
    Posts
    33
    Battery fits crna72 just get the expansion kit,..Just a quick update My vxl fried...So for christmas my wife got me a 2200kv mamba monster. Its wicked and im not having any overheating issues with it. the spur is a 24 tooth nitro revo spur and a mod1 pinion and im using a proline tranny so it bolts right up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •