Results 1 to 4 of 4
  1. #1
    RC Enthusiast
    Join Date
    Apr 2011
    Posts
    24

    TQi throttle and steering mixed ?

    Good morning all,

    I am having an issue with my TQi 5 channel. It is odd, but it seems like Ch-1 and Ch-2 are mixed !

    No response to throttle input, however when I am steering then the throttle and steering kicks in as if the channels were mixed as on my helicopter radios.

    I have tried it all, from switching throttle and steering to resetting and rebinding but to no avail !

    Any help is appreciated.

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    Have you noticed that Traxxas receivers have TWO channel 1 ports?
    Whatever it is I just typed... could be wrong.

  3. #3
    RC poster
    Join Date
    Jan 2012
    Posts
    4
    Quote Originally Posted by Jimmie Neutron View Post
    Have you noticed that Traxxas receivers have TWO channel 1 ports?
    No I did not, but thank you for nicely pointing that out to me...

  4. #4
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    It is something unique to Traxxas receivers and is commonly missed.
    Now that you have done it once, I bet you won't do it again! lol
    Whatever it is I just typed... could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •