Results 1 to 10 of 10
  1. #1
    RC Competitor
    Join Date
    Aug 2011
    Location
    lost in the woods
    Posts
    98

    velineon system esc question

    is it normal when my esc goes into lvd mode that i cant use the button to turn the esc off? the only way i can turn it off is by unplugging the battery?

  2. #2
    RC Qualifier
    Join Date
    Jul 2011
    Location
    cali
    Posts
    444
    no you should be able to turn it off. button might be sticking.

  3. #3
    RC Racer
    Join Date
    Aug 2012
    Location
    San Jose, California
    Posts
    120
    Quote Originally Posted by spewya View Post
    is it normal when my esc goes into lvd mode that i cant use the button to turn the esc off? the only way i can turn it off is by unplugging the battery?
    My sons three month old Stampede 4x4 and my year old Stampede 4x4 are this way too. Always have been. Its rare that we use the button to turn it off anyway. We only use the button to turn it on. When its not in LVD mode, if we need to use the button to turn it off, it works every time.
    Last edited by lowsaturn; 11-28-2012 at 09:54 AM.

  4. #4
    RC Competitor
    Join Date
    Aug 2011
    Location
    lost in the woods
    Posts
    98
    if my button is sticking then wouldnt i have a hard time turning it on?

  5. #5
    RC Champion
    Join Date
    Jan 2012
    Posts
    1,984
    its not the mechanical actuation of the on off switch, its an electrical malfunction

  6. #6
    RC Qualifier
    Join Date
    Jun 2012
    Posts
    717
    Mine sometimes won't turn off when it's in Lvd mode.

  7. #7
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Saskatoon, Canada
    Posts
    480
    Its best just to unplug the battery after use, I was told that when I bought my first RC last year.

  8. #8
    RC Competitor
    Join Date
    Aug 2011
    Location
    lost in the woods
    Posts
    98
    Ok .. and another thing .. one of my batteries goes into lvd mode when it has 4.xxx volts per cell?

  9. #9
    RC Qualifier
    Join Date
    Jul 2011
    Location
    cali
    Posts
    444
    +1 red i seem to remember when i did unplug the bat the button reset itself. had that issue couple months back with my son and grandsons trucks. button wouldnt let me turn off or or change driving modes.

  10. #10
    RC Competitor
    Join Date
    Aug 2011
    Location
    lost in the woods
    Posts
    98
    Why does one of many batteres go into lvd when it reads 4.something volt per cell

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •