Results 1 to 7 of 7

Thread: Transmission

  1. #1
    RC poster
    Join Date
    Jan 2007
    Posts
    5

    Transmission

    Truck quit pulling yesterday. Diff is full of 30K, slipper is good and buku clutch is good. Didn't see anything stripped when I removed diff. Any ideas?

  2. #2
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    what about the conrod?

  3. #3
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the wet stuff on the hot stuff
    Posts
    9,794
    Engine run? If so but the truck does not move, you'll need to find the disconnect between the two--see what moves and what does not as the power is heading to the tires.
    The Super Derecho

  4. #4
    RC poster
    Join Date
    Jan 2007
    Posts
    5
    Engine runs great. Gonna have to pull the transmission I guess and see what's up.

  5. #5
    RC poster
    Join Date
    May 2009
    Location
    Huntsville, al
    Posts
    11
    Did you check your wheel hex and hex pins?
    Babe, why can't I buy 1 more?

  6. #6
    RC poster
    Join Date
    Jan 2007
    Posts
    5
    Got it up and running. It was he tranny. Stripped the pin out of the primary gear. Ain't nothing easy about doin that job and I'm gonna have to do it again because I had to use old parts.

    Wheel hex and pins? Haha. That's a good one but not as good as connecting rod.
    Last edited by cooleocool; 12-03-2012 at 05:29 PM. Reason: post merge

  7. #7
    RC poster
    Join Date
    May 2009
    Location
    Huntsville, al
    Posts
    11
    Just trying to help, It happened to me before, I realize you have experience just by the parts you named and the changing of your diff fluid,did not mean to insult you, HAHA. Glad you got it fixed. If your not breaking them your not driving hard enough
    Babe, why can't I buy 1 more?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •