Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    Nov 2012
    Posts
    2

    Angry Traxxas Slash 2WD Shuts off Suddenly (Velenium motor)

    I replaced my 2WD Traxxas Slash Receiver with a new Traxxas TQi Top Qualifier Controller and and reciever. Now all of a sudden my car will shut off suddenly. I have checked the motor, and it is not hot when this happens. It usually happens about a minute after I am driving my car. The steering still works, its just the wheels will not spin.

    In order to get it going again, I cannot just press the button on the ESC to turn it off and on again. I have to unplug the battery and re plug it in, and then I can turn it on again. I'll run it again for a minute or so, and then it will shut off again. I basically can't run the car at all right now!!!

  2. #2
    RC Competitor
    Join Date
    Jun 2012
    Posts
    64
    i had that issue i had to get a new motor but first try to recalibrate the esc and if that doesnt work recalibrate the controller if all else fails call traxxas suport

  3. #3
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    5,986
    It sounds like the lipo cutoff is shutting down the esc. Is the esc light green? If it's red you're in the nimh setting and need to reprogram.
    My Black & Blue Rally is faster than your color...

  4. #4
    RC poster
    Join Date
    Nov 2012
    Posts
    2
    how do u recalibrate it

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •