Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Nov 2012
    Posts
    1

    Revo EZ-Start Problems

    I just purchased my Revo 3.3 off craigslist a week ago and the guy told me all I needed to do was replaced the Receiver. I replaced the receiver and now after I charged the batteries, I will plug the ez-start into the port and the lights on the ez-start will not light up. I will pull it out and push the button and the lights will light up. AFter I insert it back in, the lights will not light up again. The voltage on the 7.2 battery will not go above 5.4V. I am thinking there are more electrical problems than I can think of but I am taking them one at a time. If anybody has any kind of advance it would be greatly appreciated.

  2. #2
    RC Competitor
    Join Date
    Sep 2012
    Posts
    72
    what do u mean the 7.2 battery will not go above 5.4v? if it was recently charged, u will probably need a new battery.

  3. #3
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Tanker 822
    Posts
    9,675
    Do you have a multi-meter? Make sure the battery is fully charged and install into the wand. The ports for the starter motor should read the same as the battery and the glow plug should read around 1.5v. If neither of those then get a new battery and use. Just don't spend a lot of money on a new one as eventually--if you are in the hobby long enough--you will get rid of the starter system and go with pull start.
    The Super Derecho

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •