Results 1 to 11 of 11
  1. #1
    RC poster
    Join Date
    Mar 2012
    Posts
    11

    Mamba ESC Fan stopped working...

    I appreciate all the advice I have been given thus far for my newly purchased Erevo Mamba.

    I couldn't wait for my roll cage, used it today and flipped it really hard on the body on cement. Now when I cycle the ESC at the start, the fan does not come on at all. From appearances, the fan blades seem to be in tact. This thing is a monster though. It still runs just fine, but knowing the fan is not engaging, makes me real nervous about running 6s, and pretty nervous about a 4s.

    What could be wrong if esc still works fine but fan won't spin? (Only reply if you own or are very familiar with mamba esc's)

    Thanks in advance for your reply.

  2. #2
    RC Qualifier
    Join Date
    Feb 2011
    Location
    Detroit, MI
    Posts
    405
    You can get a replacement fan from castle really cheap or free if your car is new. The fan comes on at 150 and I would not run without it. The Hobbyshop may have one as well. Check the connection wire it may be unplugged, I can't see the fan breaking on a roll or jump

  3. #3
    RC Champion
    Join Date
    May 2010
    Location
    Nova Scotia ,Canada
    Posts
    1,246
    You shouldn't have any issues running 4s with reasonable gearing and no fan. Just watch the temps.

  4. #4
    RC Qualifier
    Join Date
    Dec 2010
    Posts
    299
    Try spraying the fan with some lube. I used silicone spray on mine.
    Last edited by Shadow7g; 05-14-2012 at 08:04 PM.

  5. #5
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,820
    Make sure it is still pluged in, & doesn't have a rock or something blocking the fan from spinning.
    http://www.castlecreations.com/suppo...nster_case.pdf
    Would you go flip my truck back over??

  6. #6
    RC Competitor
    Join Date
    Feb 2013
    Location
    Belgium, Antwerpen
    Posts
    60
    My fan started a few days ago making strange sounds (sometimes), maybe because there is sand in because I was drivning in loose sand.
    Last edited by Jasper Wouters; 04-08-2013 at 01:25 PM.

  7. #7
    RC Qualifier
    Join Date
    Mar 2011
    Location
    Uk... Peterborough
    Posts
    470
    Quote Originally Posted by Jasper Wouters View Post
    My fan started a few days ago making strange sounds (sometimes), maybe because there is sand in because I was drivning in loose sand.
    invest in an outwear cap dude.... it'll keep so much dirt off the chassis.

  8. #8
    RC Competitor
    Join Date
    Feb 2013
    Location
    Belgium, Antwerpen
    Posts
    60
    an outerwears shroud or something or are there better things available in Europe or in the UK that you know of?

  9. #9
    RC Turnbuckle Jr. Cameron's Avatar
    Join Date
    May 2009
    Location
    Edmonton, Alberta
    Posts
    3,592
    a trick i used before i started unning outerwears, is i will cut a peice of a bounce dryer sheet to fit in between the ESC and the mount. stops the majority of debris from having a chance to get in there. It isnt perfect, but it stops grit from getting in the top.
    (RAH) (AH) + [ROMA (1+MA)] + (GA) + (OOH)(LA)

  10. #10
    RC Qualifier
    Join Date
    Jan 2013
    Location
    The Netherlands
    Posts
    851
    Just get the outerwears or a dusty motor shroud, both are great

  11. #11
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    did you buy a replacement? mine on my maxx went out and i ordered a muchmore racing ultra high speed 30mm fan .should slide right in -might have to solder to old plug but will flow more air!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •