Results 1 to 6 of 6
  1. #1
    RC Competitor
    Join Date
    Feb 2011
    Location
    ID
    Posts
    52

    3s battery wont charge

    i tried charging my 3s 4000mah battery but my battery charger ( venom pro) says low voltage so i checked to see if the wires were cut or something and all i saw was a small cut in the negitive wire (black) but it looked to only be in the rubber aything else i should look for or somthing else wrong

  2. #2
    RC Turnbuckle Jr. 87 GN's Avatar
    Join Date
    Mar 2010
    Location
    kansas
    Posts
    7,812
    so is the wire cut?? what is your LVC set @??
    Would you go flip my truck back over??

  3. #3
    RC Qualifier
    Join Date
    Aug 2011
    Location
    delaware
    Posts
    937
    check what the cell are at , idk if you charger will display that info

  4. #4
    RC Qualifier
    Join Date
    Oct 2010
    Location
    NJ
    Posts
    777
    Quote Originally Posted by 4sdash View Post
    check what the cell are at , idk if you charger will display that info
    Or check with a Cell-log.

  5. #5
    RC Turnbuckle Jr. rjm2519's Avatar
    Join Date
    Feb 2008
    Location
    Fl
    Posts
    3,062
    Use a meter and check the voltages on the balance lead
    Donít handicap children by making life easy

  6. #6
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    Or check the total voltage it should be over 9 volts
    If its lower the pack is probably bad

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •