Quote Originally Posted by RCTRAIN View Post
Baldy I can't revert to old firmware since its an et-3s the 1.38 is the only one I have is there a way to download memo firmware and then instal it on a et-3s?
Thanks for the answer
I just updated to v1.38 beta. It doesn't give me an option to downgrade. I'm not sure if it can be done. There is no option like with the other castle controllers I have. From v1.33 to v1.38 is only over temperature behavior. I just updated and haven't tried it.

Sent from my Samsung Galaxy S III ~ using Xparent Green Tapatalk 2