Results 1 to 9 of 9

Hybrid View

  1. #1
    RC Competitor
    Join Date
    Oct 2012
    Posts
    68

    need advice... slipping out of gear

    so i just finished reassemble on my 3.3. runs amazing, got it to idle very well. i also adjusted the clutch and has very little slipping. it shift 1st to 2nd normally.
    my trouble is when i come to a stop or slow down to turn, then get into the throttle again it goes nowhere. it keeps slipping into neutral. after 2 tanks and walking after it to slap it back into gear, and looking over my assembly i need help. i know very little about the servos and how the linkages should be together so it could very well be something with that.
    any advice or help would be great

  2. #2
    RC Racer
    Join Date
    Aug 2012
    Posts
    191
    There is no neutral, if it gets going good then I wouldn't think the slipper clutch is slipping to much but worth checking it just in case. But sounds like maybe something is slipping inside the trans or something, might be worth pulling it apart & checking it out, may be something wrong in there.
    REVO 21tm grunt & JQ Products "The Car" GO NITRO

  3. #3
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the wet stuff on the hot stuff
    Posts
    9,770
    Does your truck have reverse?
    The Super Derecho

  4. #4
    RC Competitor
    Join Date
    Oct 2012
    Posts
    68
    had it out again and when i came to a stop it went into reverse, stopped again then went no where. driving me nuts, haha

  5. #5
    RC Racer
    Join Date
    Aug 2012
    Posts
    191
    Seems like the problem might be inside the trans somewhere, is the optidrive all working properly, if it has optidrive that is, (im reasonably new to revo myself). If your slipper clutch is good & it goes well until you slow or stop then I would think it would have to be a trans problem maybe, might need some new parts in there. Is the clutch on the engine in good condition also. When it stops going after slowing down to turn or stopping, does the slipper clutch still spin when you give the engine some throttle, can you see the slipper clutch shaft on the other end of the slipper clutch spinning.
    REVO 21tm grunt & JQ Products "The Car" GO NITRO

  6. #6
    RC Competitor
    Join Date
    Oct 2012
    Posts
    68
    very good advice, i will hopefully have time to take another look or tear into it more today. the slipper clutch is fairly new but i will look again to watch for that. thanks

  7. #7
    RC Qualifier
    Join Date
    Feb 2011
    Posts
    392
    Mine was doing the same thing when it goes into "neutral" take and push the shifter in if it clicks back into forward is the servo or opidrive I just went ahead and did forward only
    drive it like you stole it

  8. #8
    RC Qualifier
    Join Date
    Jun 2011
    Location
    Copple Crown Mountain
    Posts
    389
    Try taking out the opti-drive and see if that solves it. I had to take mine out, solved that problem for me. Make sure you come to complete stop and let the engine idle down before shifting. My reverse gear has stripped twice now. Just installed a "trimmed"down forward gear inplace of the stock reverse gear, working well so far.

  9. #9
    RC Competitor
    Join Date
    Oct 2012
    Posts
    68
    I went thru everything again. Seemed like channel 3 servo was not connected properly. Reconnected and reprogrammed opti-drive. Ran 1 tank and it slipped out of gear only a few times. The only thing i noticed was that the clutch seemed a little to tight, would that cause it to slip out when i stop??? Ill try to adjust to see what happens. Thanks for all advice, what do u guys think?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •