Results 1 to 9 of 9
  1. #1
    RC poster
    Join Date
    Oct 2012
    Posts
    7

    Help diagnosing problem

    Summit goes in reverse slowly whn I take my finger off trigger. Twitches too.

    I discovered that when I unplug the esc from the rcvr the twitching stops. Bad esc?

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,279
    Try recalibrating the ESC to the controller.
    Make sure to set everything to zero first!
    Whatever it is I just said... I could be wrong.

  3. #3
    RC Qualifier
    Join Date
    Dec 2011
    Location
    Saskatoon, Canada
    Posts
    480
    Your Summit won't work if you unplug your ESC from your receiver. Your transmitter sends a signal to your ESC thru your receiver, your ESC then tells your motor what to do. If your ESC isn't plugged in, your motor won't get a signal. No signal, no movement. I think thats how it works. If I am wrong someone please correct me.

  4. #4
    RC poster
    Join Date
    Oct 2012
    Posts
    7
    Jimmie - I have had this problem for a very long time. Longer than I can admit. But your suggestion worked perfectly

  5. #5
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,279
    That is good news!
    Mine used to do the same thing... even wouldn't go into reverse because it was so far out of adjustment.
    Whatever it is I just said... I could be wrong.

  6. #6
    RC Champion
    Join Date
    Apr 2011
    Location
    woodstock .on.canada
    Posts
    2,185
    aww that happened to me. its awsome for crawling dont have to stop for a seconed or so just put it in nutral at low speeds and slow smooth revers
    but unfotuniantly i rebinded the rx/tx and lost that .but i have yet to fiddel with the throttle trim to see if i can get it back
    summit /mustang /stampede-2s spc lipo

  7. #7
    RC Champion
    Join Date
    Nov 2010
    Posts
    2,006
    Quote Originally Posted by Marshnoob View Post
    Summit goes in reverse slowly whn I take my finger off trigger.
    Long ago mine did the same thing, so I reversed the servo ( so it would go forward) and called it
    "Automatic Hill Descent"
    MAN, Use Common Sense
    Funky Gecko, SumVee HDE

  8. #8
    RC Competitor
    Join Date
    Feb 2012
    Posts
    62
    Quote Originally Posted by Jimmie Neutron View Post
    Try recalibrating the ESC to the controller.
    Make sure to set everything to zero first!
    This is exactly why I love this forum. I'm having the same problem only thing is how do I make sure everything is at zero? Thanks


    Sent from my iPad using Tapatalk HD

  9. #9
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,279
    The multifunction knob is the hardest to make sure everything is at zero... but if I were having issues, I would simply reset the entire controller back to factory. "How to" is explained on the little sheet in the base of the radio.
    Whatever it is I just said... I could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •