Results 1 to 12 of 12
  1. #1
    RC Racer
    Join Date
    Sep 2012
    Posts
    168

    broke the tip off of my antena, any sugestions for a home fix (tqi 5channel)

    so i broke the tip off of my antena, there a little bit that comes out past the metal part.
    any ideas on how to fix it. i try soldering some brass wire on the end. but no go on that. any one have any ideas before i spend 36 or so for a new unit for the 50 cent wire i broke.

  2. #2
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Pittsburgh, PA
    Posts
    662
    Are you talking about the Tq remote? The TQI doesn't have an antenna. Or are you talking about the receiver? If its the receiver, just save yourself the headache and buy a new one.
    Last edited by Maxximum Overdive; 10-14-2012 at 11:01 PM.

  3. #3
    RC Racer
    Join Date
    Sep 2012
    Posts
    168
    youve got every generation
    its the tqi antena, the one the comes of the rx. the should be a little tip that comes out of the metal part. i lose my signal after 20 feet or so

  4. #4
    RC Turnbuckle Jr.
    Join Date
    Mar 2012
    Location
    so cal
    Posts
    9,244
    Its a coaxial cable. Loss cause buy a new one!

  5. #5
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Pittsburgh, PA
    Posts
    662
    I would just get a new one since 2.4ghz is very finicky without that piece of wire that sticks out past the metal tip and its really tough to get right once it's gone. Think of it this way. Would you rather pay $36 for a new receiver or $299 for a new Merv after you lose signal and a car runs over your whip? I know I'd pay $36 for the piece of mind.

  6. #6
    RC Racer
    Join Date
    Sep 2012
    Posts
    168
    kinda figured it was a loss cause. was just curious if anyone found a home remedy. its a shame. this is going to slow my sv2 plans

  7. #7
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Pittsburgh, PA
    Posts
    662
    Ya that does suck, but better safe than sorry.

  8. #8
    RC Racer
    Join Date
    Sep 2012
    Posts
    168
    o well, by the time im done fixing and upgrading this thing should be gold plated

  9. #9
    RC Racer
    Join Date
    Sep 2012
    Posts
    168
    so i think i got it. some on here told me how he fixed his, so i figured i would give it a try. it striped the wire down before the metal tube part.its just like a teny weeny coax like on your cable. i i attached about 6inch am antena wire i had and left about 1/2 of the end exposed and 1/4inch pulled down the outside of the blue antena tube.
    results
    i got about 175 yards, no glitchs until this point.
    i had two apartment buildings between me and the receiver, i had no line of sight on the receiver.
    in addition the entire road is lined with metal garages, and i have 2 radio towers about and 1/2 mile away.

    gona drive tomorow and see how it works, if all is good do some soldering. and good do go for sv2

  10. #10
    RC Racer
    Join Date
    Sep 2012
    Posts
    168
    well it works. still might get a new, cheap insurance

  11. #11
    RC Qualifier
    Join Date
    Jul 2012
    Location
    Baltimore, Maryland
    Posts
    390
    One small step for man one giant leap for rc enthusiast. Good job at least you got something and that's probably enough to run on a track.
    BB MERV/550 Rusty/OS21REVO
    Drive it like its Hot

  12. #12
    RC Racer
    Join Date
    Sep 2012
    Posts
    168
    i redid all the wiring again. must cleaner and soldered the connection. seems to work pretty good, still dont trust 100%. im goin to work it good tomorow and well see. its a pretty easy fix if anyone has this same issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •