Results 1 to 5 of 5

Hybrid View

  1. #1
    RC Enthusiast
    Join Date
    Jan 2012
    Posts
    28

    Traxxas TQi- Steering channel works, but not throttle

    Hey all, I have an issue as stated in the thread title. I bought myself a slash 2wd today from the LHS. to my pleasant surprise as I went through the box (never looked at the stuff printed on the box, just paid the 260.00 and walked out lol), it came with a TQi. well my happiness didnt last long. I had a brushless motor/ESC in a box and a set of big bores so I installed them all and when I went to run my slash for the first time I found out i had no throttle at all. I could steer left and right all day, but no forward or reverse. I tried re-setting and re-binding the radio to rx, nothing. played with it for an hour before grabbing another radio system and the truck ran normal. I hooked up the TQi to another truck, same problem. Bench tested it using the Xl5 and motor I just took off the slash and another XL5 and motor i had in a box..same thing. I hooked up the ESC to channel 1 and when I turned the wheel the motor ran normal so I know for sure its a radio system issue and not in the ESC/motor . My question is, where do I go from here? Is there anything I can do here at home to get it working or is it a defect? if I call traxxas will they require a reciept to do anything? when I bought it, I paid cash and the receipt printer was out of ink so I told the guy working to not worry about it as I was running late and ive never ever had a problem OTB with a traxxas product and I've owned 5 traxxas rigs. I'm pretty bummed out and just wanna get this thing working properly. I dont feel I should have to go back to running an AM radio because the good 2.4 system it came with is broken. thanks for any help and advice.

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    Brushless and AM usually don't play well together... so I would try to stay away from that as much as possible.

    Give Traxxas a call... they will give advice over the phone whether the RC is first hand, second, or your the 100th owner.
    If the issue is a common one or you get a nice representative, they may fix it under warranty without a receipt... they have for me in the past.
    Whatever it is I just said... I could be wrong.

  3. #3
    RC Enthusiast
    Join Date
    Jan 2012
    Posts
    28
    ive never had an issue with am radios performance as long as the wire remains in perfect shape. the minute the insulation gets cut, the truck sometimes gets twitchy. I just hate the range. its so poor. I cant even make it to the end of my street before it runs out of range and my street is not horribly long. I still see the truck plain as day.

    Anyway, thanks for the advice. Now that traxxas support lines are open, I'm gonna give them a call.

  4. #4
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,283
    Let us know how it turns out!
    Whatever it is I just said... I could be wrong.

  5. #5
    RC Enthusiast
    Join Date
    Jan 2012
    Posts
    28
    well i called up traxxas, their customer support really is top notch and the guy i talked to said he emialed me a return order invoice so all i need to do is get a receipt of any form from the LHS i got it from and send the unit to them and they will get me a new one so im pretty pumped about that. he said it could even be in the form of a handwritten receipt, as long as it shows i got it from the LHS on october 4th im good. i called the LHS and the owner said he'd be happy to get me set up with a receipt so i can get the problem resolved so im getting one tomorrow on my lunch break and hopefully will have it sent out by monday and see what happens next. thanks again for the advice, much appreciated!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •