Results 1 to 7 of 7
  1. #1
    RC Racer
    Join Date
    Sep 2012
    Posts
    227

    clicking steering servo.

    so this is the 6th time I've driven my Summit and the steering servo is week and I think it is striped. When turning to the right it doesn't have the power to turn all the way. If I lift the front wheels of the ground it will turn fine. I'm not positive which servo it is tho. Could it be something other than what I think it is? It will turn fine in the other direction tho...... I really don't know what it is ..

  2. #2
    RC Qualifier
    Join Date
    Feb 2012
    Location
    Iowa/ill/KS
    Posts
    351
    Disconnect the servo arms and manually check steering to make sure nothing is binding although its pretty much always the servos. Pretty easy to burn one up and have the opposite one strip out trying to steer while fighting a dead motor. Good start though to make sure everything is moving properly.

  3. #3
    RC Turnbuckle Jr. jamann's Avatar
    Join Date
    Sep 2009
    Location
    Victoria B.C Canada
    Posts
    5,166
    My guess would be one servo has some teeth missing.unhook one servo horn at a time.
    lift front of truck,better yet put it on a stand or a gallon paint can whatever you store it on.you should store it with the suspension unloaded.
    turn slowly while giving slight resistance with your hand.
    If turns smooth check the other one the same way.
    If there are teeth missing you should be able to tell by the feel of it.it will stutter a bit or stop "pushing" against your hand


    Sent using lipo power
    Last edited by jamann; 09-21-2012 at 07:08 PM.
    Mountains cant stop me
    they have tried

  4. #4
    RC Racer
    Join Date
    Sep 2012
    Posts
    227
    thanks guys I'll check and see. If I do need to replace one is there a better one you'd recomend that will last longer? I beleve in upgrading when it is time to replace, if you get my drift.

  5. #5
    RC Turnbuckle Jr. jamann's Avatar
    Join Date
    Sep 2009
    Location
    Victoria B.C Canada
    Posts
    5,166
    There are a few threads here on that very subject.I am running a single hitec
    If you do upgrade a aluminium servo horn is also a good idea.Bellcrank some run aluminium some don't.I do
    Steering is very good now.


    Sent using lipo power
    Last edited by jamann; 09-21-2012 at 08:40 PM.
    Mountains cant stop me
    they have tried

  6. #6
    RC Competitor
    Join Date
    Jul 2012
    Posts
    50
    Mine was doing this also. I was able to open the servo up and repair it. I had chipped a tooth off. I think there was a tab I had to cut off the gear so I could spin it 180 around to use the other side. I think the tab was just a dead stop. If you find out it is the servo don't be afraid to try and fix it. Cause if you can't or make it worse, you all ready needed a new one.

  7. #7
    RC Racer
    Join Date
    Sep 2012
    Posts
    227
    new hitec servo on it's way....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •