Results 1 to 7 of 7
  1. #1
    RC poster
    Join Date
    May 2012
    Posts
    7

    Summit EVX 2 esc dead?

    hi,
    a few days ago, when i went to turn on the esc in my summit, it turned on, and i had no throttle.. i still had steering and i could shift gears and lock the diffs but i had no throttle.. i took the body off and i saw the esc light wasent on but the reciever light was on. So, i turned off the truck and after waiting a few seconds turned it back on. I saw that the esc light would turn green for a few seconds, and then it would just go black.. does this mean that my esc is dead or is the motor burned out or what? i have tried re programing the esc, unplugging the motor wires, and i have tried unplugging certain servos from the reciever to see if it was just a bad servo.. and so far, nothing has worked...
    thanks

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,282
    Have you hooked a battery directly to the motor?
    Whatever it is I just said... I could be wrong.

  3. #3
    RC poster
    Join Date
    May 2012
    Posts
    7
    Quote Originally Posted by Jimmie Neutron View Post
    Have you hooked a battery directly to the motor?
    no, because i dont have any batteries with that kind of connecter on them..

  4. #4
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,282
    You should be able to put the motor leads into the TRX connector far enough to make contact.
    This only needs to be done for a split second... enough to see if the motor spins.
    Whatever it is I just said... I could be wrong.

  5. #5
    RC Turnbuckle Jr. humayrayakongkinaon's Avatar
    Join Date
    May 2011
    Location
    Long Beach, California
    Posts
    6,578
    and make sure do take precaution when you directly plug the batt to motor. have the truck off the ground.
    | Rally GT8 Powered By CC | BackSl4sh Roadrunner |

  6. #6
    RC Turnbuckle Jr. humayrayakongkinaon's Avatar
    Join Date
    May 2011
    Location
    Long Beach, California
    Posts
    6,578
    Quote Originally Posted by Aking720 View Post
    hi,
    a few days ago, when i went to turn on the esc in my summit, it turned on, and i had no throttle.. i still had steering and i could shift gears and lock the diffs but i had no throttle.. i took the body off and i saw the esc light wasent on but the reciever light was on. So, i turned off the truck and after waiting a few seconds turned it back on. I saw that the esc light would turn green for a few seconds, and then it would just go black.. does this mean that my esc is dead or is the motor burned out or what? i have tried re programing the esc, unplugging the motor wires, and i have tried unplugging certain servos from the reciever to see if it was just a bad servo.. and so far, nothing has worked...
    thanks
    could it be your battery? are you using lipo or nimh?
    | Rally GT8 Powered By CC | BackSl4sh Roadrunner |

  7. #7
    RC poster
    Join Date
    May 2012
    Posts
    7
    Quote Originally Posted by Jimmie Neutron View Post
    You should be able to put the motor leads into the TRX connector far enough to make contact.
    This only needs to be done for a split second... enough to see if the motor spins.
    i just tested the esc with a voltmeter to see if it was pumping out any voltage and it is not.. and i did what you said and the motor is fine.. thanks for your help!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •