Results 1 to 5 of 5
  1. #1
    RC poster
    Join Date
    Jan 2012
    Location
    Canada Ontario
    Posts
    11

    Traxxas 3.3 engine problems pleasseeeee hellppppp meeeee!!!!!!!

    my 3.3 engine will not run for more than 5 seconds unless i i have full throttle, i recently changed the carb and thats when it stopped running, i put all needles to factory settings and it still wont run, i also checked the clutch and thats fine, also the engine DOES have compression! any sugestions will help please and thanks
    slayer

  2. #2
    RC Champion
    Join Date
    Mar 2012
    Location
    Grafenwoehr Germany
    Posts
    1,304
    Do u have the old carb?

  3. #3
    RC Competitor
    Join Date
    May 2011
    Location
    Zion, IL
    Posts
    78
    Dude, you've posted the same thing twice now in the Full Size Short-Course Off-Course Racing forum. Just a thought, but you might get more help in the right forum.

    Try here.
    Slash VXL
    Grave Digger 'Pede
    30th Digger 'Pede

  4. #4
    RC poster
    Join Date
    Sep 2012
    Posts
    1
    try these settings high speed needle 4 1/2 turns out and the low speed needle flush or 2 1/2 turns out try starting it with out the air filter

  5. #5
    RC poster
    Join Date
    Sep 2012
    Posts
    6
    I think the problem in carb.Try to change and use another one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •