Results 1 to 8 of 8
  1. #1
    RC Competitor
    Join Date
    Aug 2012
    Location
    Canada,Quebec
    Posts
    59

    need help with my slayer

    Yesterday i took out my slayer and it was runing great .. After 15min run out of gaz i refill it and i press on gaz but nothing happen i chek it and my servo wasnt moving ... After changing my batterie nothing ... So i try to see if it something wrong onder there and i saw my u-joint for rear whell was off so do you think it my servo becaus it new 2056 waterproof?
    Last edited by slayerQc; 08-29-2012 at 10:45 AM.

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Putting the wet stuff on the hot stuff
    Posts
    9,842
    Plug the steering servo into the throttle port on the receiver and the throttle servo into the steering port. With the engine off and power on test them. If the steering servo moves but the throttle still does not, then you've isolated the problem to the servo. If the throttle now moves then the problem is with the tx or rx.
    The Super Derecho

  3. #3
    RC Turnbuckle Jr. Wolfslash16's Avatar
    Join Date
    Mar 2012
    Location
    Riverton Utah
    Posts
    4,401
    Plug the steering servo into the throttle port on the receiver and the throttle servo into the steering port. With the engine off and power on test them. If the steering servo moves but the throttle still does not, then you've isolated the problem to the servo. If the throttle now moves then the problem is with the tx or rx.
    +1 Maybe you ran through a puddle and water got it the receiver? If not, I hate to say it, but maybe your servo went bad? Hope this helps!
    Sl2sh Slayer Summit Sl4sh Teton/Rally T-Maxx Pnde

  4. #4
    RC Competitor
    Join Date
    Aug 2012
    Location
    Canada,Quebec
    Posts
    59
    I thoug my servo is bad to ... I plug it into stering and blablabla ... still not working ... i unscrew the arm on my servo and it was working proprely ... then i adjust evry thing tight the screw evry thing was working .. i took it outside i start it and not working ... + idle screw was not open eghoug the car stop after 5 sec...

  5. #5
    RC Competitor
    Join Date
    Aug 2012
    Location
    Canada,Quebec
    Posts
    59
    problem solved cuted wire to my servo little iron and evry thing is back on track

  6. #6
    RC Competitor
    Join Date
    Aug 2012
    Location
    Canada,Quebec
    Posts
    59
    Is here some one who know what is the best SERVO that i can put in my slayer pro 3.3 ? at the moment i have trx 2056 but is there another brand better then that? Ill will to have waterproof and not expensive...

  7. #7
    RC Competitor
    Join Date
    Aug 2012
    Location
    Canada,Quebec
    Posts
    59
    You are true my servo went bad the wire was cut when i open it .. I did some iron on it it work fee minute and then it realy dead ! XD what is the best servo price + quality that i can get for my slayer throttle?

  8. #8
    RC Qualifier
    Join Date
    Oct 2011
    Location
    naptown
    Posts
    589
    I run a hitech servo in my pro and love it can't remember which one i got think it was the 62 or 65mg but have been running that one since last summer and have no complaints. that one was around $33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •