Results 1 to 4 of 4
  1. #1
    RC Racer
    Join Date
    Dec 2005
    Location
    Midwest
    Posts
    129

    KO Propo PDS-3101 just bit the dust.

    By the symptoms displayed, it appears as if the electronics have gone crazy. That stinks. Probably less than 10 packs ran through it. It has never seen water or mud. Looks like I will be re-installing the stocker for now. I may try the 390 servo. Anyone else have a similar experience? Any anecdotal evidence from anyone who has used both that one or the other should work any better? Trying to keep this thing running for my son is becoming a full time job. Thanks in advance for the assist.
    Last edited by ksb51rl; 08-28-2012 at 11:38 AM.
    Tekno wing mount, Pro-Line wing, Maximizer X-75s, and Maxx Mashers.

  2. #2
    RC Turnbuckle Jr. JimmyNeutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, Michigan
    Posts
    12,290
    Over 200 packs on my 390. No issues.

    You should PM a mod to ask him to edit out your T word. It is a like a swear word around here and points can be issued.
    Whatever it is I just typed... could be wrong.

  3. #3
    RC Racer
    Join Date
    Dec 2005
    Location
    Midwest
    Posts
    129
    Ahhhhh!! Thanks for both the shared experience and the heads-up.

    PM sent. Thanks.
    Last edited by Rick's Revo; 08-28-2012 at 11:06 AM. Reason: PM update.
    Tekno wing mount, Pro-Line wing, Maximizer X-75s, and Maxx Mashers.

  4. #4
    RC Racer
    Join Date
    Dec 2005
    Location
    Midwest
    Posts
    129
    Thanks ksb.
    Tekno wing mount, Pro-Line wing, Maximizer X-75s, and Maxx Mashers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •