Results 1 to 3 of 3
  1. #1
    RC Racer
    Join Date
    Jan 2012
    Location
    Duncansville, Pennsylvania
    Posts
    102

    Need Help With LRP Spec 3 and Bouncing Tires

    I recently installed a lrp spec 3 in my revo with the new era engine mount. The throttle linkage works fine, it opens the carb all the way and returns closed. but it only works when the engine is off or has been running for about less than 3 minutes. Then the servo wont open the carb. its like when the engine gets hot the carb stops opening. When I let the engine cool down it works fine again. I know the engine is not to lean, its actually very rich. also i have a problem with my right front wheel, it bounces at high speed and i'm not sure how to fix it.
    thanks in advance!

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Tanker 822
    Posts
    9,629
    With the engine/carb problem, you'll need to consult the manufacturer of the engine for support. Non-Traxxas support is not allowed here.
    As for the tires, check to see that there is nothing caught inside the tire, the foam feels even but above that you may need to balance the tire. Just remove the driveshaft between the diff and the axle and spin the tire. Put some weight on the upper side of the tire and spin it until it stops at random.
    The Super Derecho

  3. #3
    RC Racer
    Join Date
    Jan 2012
    Location
    Duncansville, Pennsylvania
    Posts
    102
    Will try that. thanks.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •