Results 1 to 3 of 3
  1. #1
    RC poster
    Join Date
    Jul 2012
    Posts
    4

    Receiver light flashing

    Hey there everyone. new to the forum and also fairly new to the summit scene. Got a ton of help lurking on the forums already (thanks to all) but cannot seem to find any answers regarding my newest issue.

    Was driving around on saturday night in my 1/16 summit VXL, and all the sudden I lost all power. My Tx was not responding to my rx... warning lights

    Had my Radio Transmitter with a solid green light.
    Had my receiver flashing rapidly red.
    Had my ESC flashing VERY dim red.

    Tried unpluggin my servo and I regain all power and the lights turn to solid green on my ESC (lipo) and I regain throttle response. As soon as i plug my servo back in I get the lights flashing red again. and cant do jack.

    any ideas?

  2. #2
    Traxxas Employee
    Join Date
    Jan 2011
    Location
    Plano,TX
    Posts
    51
    Sounds like you may have a Bad servo. For troubleshooting help and advice give traxxas support a call at 1-888-TRAXXAS (872-9927). We are open 8:30am-9:00pm CST to help with all your troubleshooting needs!!!

  3. #3
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    11,971
    I believe shutter is correct...
    Whatever it is I just said... I could be wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •