Results 1 to 10 of 10
  1. #1
    RC Racer
    Join Date
    Jun 2012
    Location
    maryland
    Posts
    110

    Slash 4x4 motor problems

    Hey guys, I have a slash 4x4 and i was running it today with a 15t pinion and stock spur with a 2s lipo,but i had to use my ezrun 30amp esc, which ive been running for about a month and suddendly, the truck just stoped. I didnt smell any thing and the motor was cool but the esc was hot and the motor wont move the car. Its just stuttering, that is what happened to my ezrun 4300kv motor and i looked and the magnet cracked. I just want to know if my motor is toast or not
    Nitro soup@urc forums-Andrew Nabb on youtube

  2. #2
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    if the motor was cool, and the esc hot, i will say the issue is the esc, there is no way to know until you start the elimination process, using diff motor or diff esc.
    Last edited by RC-Fan; 08-17-2012 at 07:13 PM.

  3. #3
    RC Racer
    Join Date
    Jun 2012
    Location
    maryland
    Posts
    110
    Im on the forums now so i can let it cool off a bit. I am about to check it and then i wil get back to you with the results.Thanks

    I just checked again same thing. So i took the motor off and took off the black cap at the end and then i took the screws out of the can, then i took the rotor out it had no cracks nothing seemed wrong with it. So i looked inside the can, it all looked good but just incase i blew it out with the air compressor and I checked the bearings, there all good. So does anybody know if my motor just blew or not?
    Last edited by cooleocool; 08-18-2012 at 09:27 AM. Reason: post merge
    Nitro soup@urc forums-Andrew Nabb on youtube

  4. #4
    RC Turnbuckle Jr. vxlrocket's Avatar
    Join Date
    Dec 2007
    Location
    Manassas, Va
    Posts
    6,623
    I'm betting it's your esc. 30 amps is tiny for that motor. I would aim for atleast 120.
    ERBE, 8ight, 8ight-t, b4,b44, scte, slash 4x4

  5. #5
    RC Racer
    Join Date
    Jun 2012
    Location
    maryland
    Posts
    110
    Ok thanks. that was just a tamporary setup for the truck anyways. I got a new slash 4x4 roller coming on sunday, do you think a hk 60amp sensored esc paired witha 11.5t 3350kv sensored setup would be good for this truck? I jnow nobody likes being asked what sytem they run at the track and having to awnser . . . But you cant beat that price

    Edited for language abuse. If you see a starred out word in your post, you must edit it out.
    Last edited by cooleocool; 08-18-2012 at 09:27 AM.
    Nitro soup@urc forums-Andrew Nabb on youtube

  6. #6
    RC Turnbuckle Jr. vxlrocket's Avatar
    Join Date
    Dec 2007
    Location
    Manassas, Va
    Posts
    6,623
    I think even a 60amp is too small. Like i said i'd go for 120.
    ERBE, 8ight, 8ight-t, b4,b44, scte, slash 4x4

  7. #7
    RC Qualifier
    Join Date
    Apr 2012
    Posts
    519
    i would personally go with a 120a

  8. #8
    RC Racer
    Join Date
    Jun 2012
    Location
    maryland
    Posts
    110
    Ok, tagnks for all the feedback. Ill try to find a 120amp or higher esc thats sencerored.
    Nitro soup@urc forums-Andrew Nabb on youtube

  9. #9
    RC Turnbuckle Jr. El Sob's Avatar
    Join Date
    Feb 2010
    Location
    El Sobrante, Ca
    Posts
    7,068
    I would personnaly go wit a Mamba Max Pro esc! I have used these esc's and they have done me very well! They will also run sensored motors extremely well
    Slash Ultimate, ET-3S, 2400, MIP, King Headz, RPM

  10. #10
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    5,796
    +1 on the MMP. They last for years and do what they're supposed to do. I like playing around with the settings on my PC.
    My Black & Blue Rally is faster than your color...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •