Results 1 to 5 of 5
  1. #1
    RC Racer
    Join Date
    Mar 2012
    Location
    Burley idaho
    Posts
    161

    Holy cow and then crap!!

    I took my summit with the vxl 3m on 2 2s today. WOW!! It was insane! I was goin good until my little bro wanted to try. Thats when things got bad. He punched off the start cause hes used to his mini t. It did a backflip into our car . After that it wouldnt go. It would only steer. The esc light isnt on and the button Isnt working. Did he break it? Any help please. Thank you

  2. #2
    RC Turnbuckle Jr. Jimmie Neutron's Avatar
    Join Date
    Oct 2009
    Location
    Alma, MI
    Posts
    12,287
    Unplug the batteries and try again.
    If that doesn't work, try unplugging the servo.
    Whatever it is I just said... I could be wrong.

  3. #3
    RC Competitor
    Join Date
    Aug 2011
    Posts
    84
    Quote Originally Posted by pede1497 View Post
    I took my summit with the vxl 3m on 2 2s today.
    You used the parallel connector and not the series one, right? VXL 3m cannot handle 4s (2 2s LiPo in series) for long.

  4. #4
    RC Racer
    Join Date
    Jun 2012
    Location
    Tazewell Va. Were so small here in taz. that we only have 3 stop lights....and one is broke
    Posts
    169
    i dont even think itll run on 4s in series...

  5. #5
    RC Enthusiast
    Join Date
    Jul 2012
    Posts
    43
    ^It will if you put it in NiMh mode, not LiPo mode. I'd still never do it though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •