Results 1 to 10 of 10
  1. #1
    RC Racer
    Join Date
    Dec 2001
    Location
    Surrey, BC, Canada
    Posts
    136

    Dissapointed in DTS-1

    NOTE: This is a long thread where I rant about the DTS-1. For a recap, scroll to the end of the post.
    Let me say from the start that I have been racing / bashing / enjoying RC cars of all types for over 30 years. I've been building and racing real, full scale, tube chassis drag cars for over 20 years. Finally, I've been in IT/Network Administration for over 15 years. I am probably the ultimate consumer for this stuff: the RC, Drag Racing, Technically inclined tinkerer type.

    10 minutes after I'd seen an announcement from Traxxas about the new drag racing stuff, I was on the the phone with my LHS. I pre-ordered two 1/8 Funny Cars, two TQi Docking Base units, a DTS-1, four 3S LiPo's, a Hyperion EOS 0720i Super Duo charger, and a bunch of other goodies. Needless to say, I jumped back into the RC hobby in a big way after a few years off.

    I was ecstatic to give Traxxas a big chunk of my hard earned money for this perfect convergence of the things that make me happy. Except...

    The DTS-1 is not ready for prime time.

    Any product that needs a firmware update -- out of the box! -- before you can use it was rushed to market. Yes, I guess you could use the DTS-1 out of the box without the iPhone / iPod Touch Docking Base, I bet the vast majority of customers want all the killer functionality that comes with the DTS-1 / iDevice combo.

    After the 20 to 30 minute firmware updates came two hours of trying to get the DTS-1 / TQi / iPhone combo to work. There is ZERO instructions in the included manual on how to do this. It got to the point where I wanted to smash the DTS-1 into smithereens. So I left it for a week to cool my head.

    A week later...
    The next time I tried to setup the system, I found instructions in the Traxxas Link app, buried under a little question mark icon. They detail a ridiculous, multi step set of hoops that you must jump through to get some success. Yet, you can't do any of the steps and see the instructions at the same time, so it's a lot of back and forth, back and forth.

    Finally, after another aggravating hour, I got the system linked and being controlled via my iPhone! I got everything setup, aligned and ready to go make my first timed run with my expensive new gadgets... except the DTS-1 was no longer linked to the TQi.

    After jumping through the hoops, again, I finally got a (one lane) race in! Except the Traxxas Link app thinks the race is still in session. To continue, you have to "Abort" the current race. Well, "that must be a mistake" I thought to myself. Let's try it again.

    Nope. Same thing. Let's look through some menus for settings... Oh, wait! The DTS-1 has unlinked from the TQi again... To keep from smashing the whole setup... I put it away for a week to cool my head again.

    Another week later...
    Oh, look! An update for the Traxxas Link app. Maybe they fixed some things! Let's update.

    And... another round of firmware updates. There goes another 45 minutes.

    So I got everything setup once more. Beams aligned, DTS-1 and TQi linked. Funny Car re-bound and relinked after the DTS-1 setup booted it off the TQi. Ok, let's go:

    And... races still don't complete themselves. Oh, and look! The DTS-1 has unlinked itself from the TQi again! It's easy enough to relink now, but every time you do, you have to link the finish line unit to the starting line unit... in 10 seconds, 100+ feet away... by yourself.

    So, I packed it all up again to calm down, when a friend called. He wants me to come by and we can race on his 200 foot long, freshly paved, perfectly flat driveway.

    Let's try this again...
    So, we spend an hour setting up the DTS-1, getting the start and finish units squared and inline, the beams perfectly aligned, his iPhone ready and installed, etc. We run our first race and you still have to Abort the current race even if two cars run a perfect race. Why, Traxxas?

    And to top it off, the DTS-1 would unlink from the TQi every 3 or 4 races. You then had to shut off both DTS-1 units, relink. It's easier to relink the finish line with two people, but it's no less of a pain in the rear.

    The DTS-1 / TQi / iPhone system is so frustrating to use that we gave up after less time than it took to set it up.

    We tried racing in manual mode for a while, but that was almost as frustrating. What do all these lights mean? How do you start a race? Oh! Of course, you press the 'Set" button; that makes perfect sense. How do you run one lane races? Oh you press "Menu" except if you want to use the right lane... then you press "Option." Of course! How could I be so stupid.

    Then, the Pièce de résistance: The DTS-1 just randomly locks up on its own. Every 4 or five races, just like when paired with the TQi.

    I don't know what else to do. At this point, I'm really considering selling it all off at loss because none of it has been the fun it should be.

    I think Traxxas has blown it so far with the RC Drag Racing stuff. It's a shame too, because Drag Racers are an odd bunch. They spend money like crazy in search of a good time, and I know dozens of guys at the track that would buy in if it worked better, or at all.

    Anyways, this very long story has been sort of therapeutic. Sorry for the ranting. For those looking for the condensed version:

    • The DTS-1 has been rushed to market. It is not finished. I've been a fan of Traxxas products since the original T-MAXX days, and this lacks the typical Traxxas polish seen in their products.
    • The system is way, way, WAY too complicated to use for the average hobbyist. My job is to make complex systems work together, and then explain how to use it to decidedly non-technical users. I barely got the DTS-1 to function at all.
    • This is 2012. There is no room for random blinking light codes and mislabeled / confusingly labeled buttons. A $3.00 2 line / 20 Character LCD would have made all the difference.
    • There is something wrong with the DTS-1 and or the TQi connection. The start / finish line units frequently lock up and stop responding.
    • The related Traxxas Link app is adequate, but also leaves much to be desired. I don't think the race functionality works as expected / intended. Plus, to start a race, you have to go into the "Garage" area? How does that make sense: "OK, I want to race, so let's go to the same place I adjust telemetry setup and transmitter memory..."
    • Far too easy to red light. You get real Drag Racers, used to drilling a Pro Tree, and they will red light 9 times out of 10. There needs to be adjustable roll out or delay box type settings.


    There is much more, but I'm tired and I want to go to bed. Plus, I'm uncertain whether this thread will end up in mod purgatory or not...
    http://www.tunamaxx.com

  2. #2
    Marshal Double G's Avatar
    Join Date
    May 2008
    Location
    Tanker 822
    Posts
    9,583
    This is good information to know and I would bet that Traxxas would review this feedback to make the system better. I can understand the frustration of wanting to use the products as advertised only to spend more time in the garage, per se, than out in the field.
    I do hope that you get your problems resolved soon and consult Traxxas' Customer Service to discuss your concerns.
    The Super Derecho

  3. #3
    RC Racer
    Join Date
    Dec 2001
    Location
    Surrey, BC, Canada
    Posts
    136
    I'd like to thank Traxxas support for contacting me about the problems I've been having with the DTS-1. They've asked me to call in and run through some troubleshooting steps to make sure everything is working right.

    As soon as I've had a chance to call them, I'll follow up here.
    http://www.tunamaxx.com

  4. #4
    RC Turnbuckle Jr.
    Join Date
    Dec 2006
    Posts
    4,377
    Great information! Mine is on the mail and will arrive in a week or so... I don't own an Ipod/Iphone yet, so, let's see what I'm against to... Does it work out of the box without an update if you don't own and Ipod/Iphone?
    200, 202, 420, humor 404, 301 to rc10talk, 410.

  5. #5
    RC Racer
    Join Date
    Dec 2001
    Location
    Surrey, BC, Canada
    Posts
    136
    As far as I know, there is no need to do any firmware updates if you are going to use the DTS-1 system without the TQi / Traxxas Link / iPhone setup.
    http://www.tunamaxx.com

  6. #6
    RC Qualifier
    Join Date
    Jul 2012
    Location
    wyoming
    Posts
    567
    well, if you do end up selling off the two cars and the system- im interested in a car or two lol, i would help ya out but i have no experience at all with the drag race cars or with the drag race system, thanks for sharring you experience about the dts system, there is no chance in the world that i will purchase that system

  7. #7
    RC Enthusiast
    Join Date
    May 2012
    Posts
    36
    TunaMaxx is correct. The system is fully functional standalone with no firmware updates required. I used it this way when I first received it and I know my LHS is also using it that way. I now use it with the TQi and iPod. It adds a lot of cool features but still lots of fun without.

  8. #8
    RC Racer
    Join Date
    Dec 2001
    Location
    Surrey, BC, Canada
    Posts
    136
    I haven't had a chance to take Traxxas Support up on their offer of help yet, but I think I'll give them a call before work tomorrow.

    I really want this to work as advertised. The fun potential is off the charts!
    http://www.tunamaxx.com

  9. #9
    RC Turnbuckle Jr.
    Join Date
    Dec 2006
    Posts
    4,377
    I agree! If you talk to them, let them know we need more information on all the TQi add-ons, like how to install the sensors, and things like that, we need that official information now!
    200, 202, 420, humor 404, 301 to rc10talk, 410.

  10. #10
    RC Enthusiast
    Join Date
    Aug 2012
    Posts
    26
    I ran accross the same problems ( 2 days of pure frusration !) and heres what i did, Use a seperate transmiter other then one using with car, any tq tx will work. Then start link app, then your tx, make sure the tx symbol turns to green on your ipod screen, if not , turn tx off then on. Then turn off and press bind on your tx while turning back on your tx, now your in bind mode. Turn on tree,while pressing the set button, you should here a beep and get 2 green lights on the tree when your done,now you should see a green tree symbol top on your ipods top right screen. YOUR DONE ! Using this method you will need to link the trap each time ( no big deal considering the headaches of the websites directions ) so to run ,,,,, 1 Start traxxas link 2, turn on tx and see green tx symbol on ipod (sometimes you will need to turn it off and back on again and let it update ). 3 QUICKLEY Turn on trap and see a green trap icon on ipod restart tx and tree if needed. 4. Press set on tree untill 2 beeps are heard, then within 10 seconds turn on trap, thats it. go to diagnostics to be sure both trap and tree are activated and working. Once in a while while sending comands to the tree you may get a link error message, disregard, and simply resend last comand and it will work again. Its been trouble free for me , mark your trap and reflector possitions on the ground with whatever you want and it will speed up setup times by10. One more thing, on the race history ,witch is very cool,the reaction times are plus 400 mileseconds, Timeslip readings are correct though. So make sure you tx is green lighted on ipod, bind it to the tree , and then link tree to trap each time . and thats it ! Good Luck
    Last edited by sjones420; 08-12-2012 at 08:19 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •