Results 1 to 6 of 6

Thread: PEDE problems

Hybrid View

  1. #1
    RC Enthusiast
    Join Date
    May 2011
    Posts
    25

    PEDE problems

    So my son took his pede out for a run last week and when he fired up the ESC it flashed green rapidly then just turned off and it was dead after that. So I bought a new one and installed it fired it up and now I get forward and reverse but the steering instantly turns all the way left but wont respond at all to the steering wheel. I changed out the crystals with new ones but still the same result. I also noticed that the new ESC heated up very quickly and I didn't even run it at all. Any thoughts??

  2. #2
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    Make sure the servo is on ch 1 and Esc is on ch 2 on the receiver. When you install a new Esc you need to recalibrate the Esc with the radio, but that doesn't explain the overheating issue, I would try a diff battery maybe, definitely not normal behaviour, you should contact traxxas customer service. I would get a castle Esc instead, Vxl-3s is well known for having issues. What batteries are you running ?

  3. #3
    RC Champion
    Join Date
    Aug 2010
    Location
    new hampshire
    Posts
    1,771
    Very good advice RC-Fan. Hops everthing works out for you Sdriv.
    I never had good luck with VXL-3S escs had 3 combos two had stuck esc buttons.The thrid was in my 4X4 Pede sold it while it was still running.

  4. #4
    RC Enthusiast
    Join Date
    May 2011
    Posts
    25
    Thanks guys I will check the channels. Can I look up how to recalibrate on the Traxxas site. I don't have the manual for his anymore. I am running the stock battery and I used that same battery in my Pede after I tried it in his and had no problems. The battery was my first thought too.

  5. #5
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    Quote Originally Posted by sdriv View Post
    Thanks guys I will check the channels. Can I look up how to recalibrate on the Traxxas site. I don't have the manual for his anymore. I am running the stock battery and I used that same battery in my Pede after I tried it in his and had no problems. The battery was my first thought too.
    Here is the manual http://traxxas.com/products/parts/escs/vxl3s-downloads

  6. #6
    RC poster
    Join Date
    Oct 2012
    Posts
    1
    traxxas support has me sending in my ESC cause it wont calibrate, nor would it pretty much do anything i want it to do.
    i see the flashing green but i have the trim on 0 and it still flashes, i tried everything the guy told me to and then hes like well something is wrong with the ESC. your gonna have to send it in with $55.00 im gonna try sending it to the hobby shop first and see what they say cause i really dont feel like losing it for that long by the time it gets to traxxas n they send me another one.. that and 55 bucks id rather hopefully spend 40 bucks n have it fixed or 55 n have it the next day lol well if anyone may have an idea on what else i can try besides calibrating it and trying to get rid of the low voltage detection or turning it on let me know cause we couldnt turn it on cause of the flashing light nor off cause of the light.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •