Results 1 to 5 of 5
  1. #1
    RC Enthusiast
    Join Date
    Jun 2012
    Location
    Delaware
    Posts
    47

    New to MMP and have some ?s

    I jut got the MMP 2400kv sct from castle hooked up and ran it alittle last night. It came with a motor fan to plug into the receiver but I don't know which slot to plug it into. I've tried them all but none make it run, any advice?

  2. #2
    RC Champion
    Join Date
    Nov 2010
    Location
    Lilydale, Victoria, Australia
    Posts
    2,845
    Any spare slot, they all share common power

    If it does not run it may be faulty

    Cheers
    Slash Platinum
    Xerun 150 / Tenshock SC401 3500kv

  3. #3
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    you don't need the fan, I never used it, that motor runs pretty cool.

  4. #4
    RC Enthusiast
    Join Date
    Jun 2012
    Location
    Delaware
    Posts
    47
    Really no need to worry about it? I live in Delaware and this time of year it's pretty common to be in the mid 90s and with humidity to have a heat index of somewhere right around 470 degrees

  5. #5
    RC Turnbuckle Jr.
    Join Date
    Jun 2010
    Location
    Miami, Fl
    Posts
    6,731
    I live in Miami when it is close to 90F, and never had a heat issue with that motor, what batt? pinion, are you running ?, also that fan is a joke it is plastic, a good fan has a heatsink made of aluminum. I recommend to get a temp gun to check your temps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •