Results 1 to 14 of 14
  1. #1
    RC poster
    Join Date
    Jul 2012
    Posts
    11

    Slash 4wd intermittently vears slightly left or right

    When I'm running the truck I noticed recently the truck will bear right or left intermittently, I've looked the steering over and I cannot see anything wrong, I am thinking it may be a servo, I am running the stock brushless motor, pro line shocks and I recently installed sway bars, all that work was done a while ago the problem just started, any suggestions? It does it when I'm running 11.1 lipo or 8.4 and it won't correct with the steering trim..
    Last edited by Billybobsgoat; 07-14-2012 at 06:35 PM.

  2. #2
    RC Champion
    Join Date
    May 2012
    Location
    friendswood texas
    Posts
    1,297
    There is an adjustment for this on the controller. No offence check the manual.

  3. #3
    RC poster
    Join Date
    Jul 2012
    Posts
    11
    Like I said its intermittent, I'm not stupid I know what steering trim is. If it was the steering trim it would be consistent. Read my thread more clearly before you cast a stupid comments, read the last line of my thread.

  4. #4
    RC Enthusiast
    Join Date
    May 2012
    Posts
    34
    are you on dirt or pavement? Also mine does that if i get on it on pavement it will veer off

  5. #5
    RC poster
    Join Date
    Jul 2012
    Posts
    11
    Pavement, but it veers when I let off the throttle but it doesn't do it all the time. Right or left on level ground.

  6. #6
    RC Turnbuckle Jr. thedreadedend's Avatar
    Join Date
    Jun 2010
    Location
    Springfield, Ma.
    Posts
    3,359
    I've run these trucks (sl4sh) with many different configs for wheels, servos, bellcranks. .. I favor the strc bell crank for it's smooth operation and a bit more through witch will also result in tighter turns and overall turn radios. Things I've come across that will cause this exact problem are, easiest first..... bearings.... wheel or diff but not likely because your talking left and right..... bell crank bearings, bottom set gets gunked up quick! I don't think its those either. The bell crank itself, the stock plastic set gets dirt built up and wears down with grit. For $9 + a new set of bearings for it for another $6-8, that's what I would do. I feel the battery you use is not a variable, bec will deliver the same power no matter what is in there unless that gets cooked. In that case, esc would be shutting down or clutching out ...... you would know it if it was a problem! Also worth mentionin,the 4x4 has a bit of slop that comes in after some use. Its hard to work it out without replacing parts like hubs, axles, teflon washers, hollow ball ends.... It would be most cost effective to replace the bell crank bearing, then the bell crank if its getting rough in the saver joint. If you have the slop I described on each front wheel, then hubs, knuckle, bearing would ne next in the line up. Eventually, a servo upgrade will be one of the major game changers! It makes a basher and racer come to life. As soon as you run a battery through it with a high torque servo, you will wonder how the heck you ever got along without it!.
    I'm not a hatchet man! I'm a maggot!

  7. #7
    RC poster
    Join Date
    Jul 2012
    Posts
    11
    Quote Originally Posted by thedreadedend View Post
    I've run these trucks (sl4sh) with many different configs for wheels, servos, bellcranks. .. I favor the strc bell crank for it's smooth operation and a bit more through witch will also result in tighter turns and overall turn radios. Things I've come across that will cause this exact problem are, easiest first..... bearings.... wheel or diff but not likely because your talking left and right..... bell crank bearings, bottom set gets gunked up quick! I don't think its those either. The bell crank itself, the stock plastic set gets dirt built up and wears down with grit. For $9 + a new set of bearings for it for another $6-8, that's what I would do. I feel the battery you use is not a variable, bec will deliver the same power no matter what is in there unless that gets cooked. In that case, esc would be shutting down or clutching out ...... you would know it if it was a problem! Also worth mentionin,the 4x4 has a bit of slop that comes in after some use. Its hard to work it out without replacing parts like hubs, axles, teflon washers, hollow ball ends.... It would be most cost effective to replace the bell crank bearing, then the bell crank if its getting rough in the saver joint. If you have the slop I described on each front wheel, then hubs, knuckle, bearing would ne next in the line up. Eventually, a servo upgrade will be one of the major game changers! It makes a basher and racer come to life. As soon as you run a battery through it with a high torque servo, you will wonder how the heck you ever got along without it!.
    Thank you for the insight, in the back of my mind I was thinking it might be bell crank or bearing related, thanks again! I'll get troubleshooting this tomorrow

  8. #8
    RC Racer
    Join Date
    Feb 2011
    Location
    Saskatchewan
    Posts
    206
    could be a hand full of things . maybe a servo on its way out?

  9. #9
    RC poster
    Join Date
    Jul 2012
    Posts
    11
    Servo was changed to a $80 Savox servo 277 in lb, still does it, next is the strc bell crank which I've purchased but haven't installed yet. But that new servo is sweet.

  10. #10
    RC poster
    Join Date
    Jul 2012
    Posts
    11
    I'm going to be proactive and change the front hub bearings too. just in case..

  11. #11
    RC Turnbuckle Jr. thedreadedend's Avatar
    Join Date
    Jun 2010
    Location
    Springfield, Ma.
    Posts
    3,359
    I change the hubs/knuckles and zero saver on my basher quite often. Just so I don't get the typical slop that comes after a few months at bashing. The Tekno parts keep it in check much better than the trx and strc parts at the wheels but the stockers are the only sets I've used that stay tight. Too bad too because I tend to brake them. I use XO1 shafts and hardware on the basher these days.... Tekno on the TRCE racer I run. I think you'll find that the bell crank will fix the wondering. If not, it will take a new set of hardware at the wheels, hubs knuckles.......I know you don't want to hear that lol. Bit hey, bearings can always use a change!
    I'm not a hatchet man! I'm a maggot!

  12. #12
    RC Champion
    Join Date
    May 2012
    Location
    friendswood texas
    Posts
    1,297
    Quote Originally Posted by Billybobsgoat View Post
    Like I said its intermittent, I'm not stupid I know what steering trim is. If it was the steering trim it would be consistent. Read my thread more clearly before you cast a stupid comments, read the last line of my thread.
    Sorry I was just trying to help. Not trying to ruin your day. Sometimes the simplest stuff gets overlooked but you are too much of an expert for that.

  13. #13
    RC poster
    Join Date
    Jul 2012
    Posts
    11
    Quote Originally Posted by pro mod steve View Post
    Sorry I was just trying to help. Not trying to ruin your day. Sometimes the simplest stuff gets overlooked but you are too much of an expert for that.
    I'm over it.

  14. #14
    RC Racer
    Join Date
    Apr 2012
    Posts
    193
    Mine does this too from time to time... I had to replace the MIP stub axle in the front, I bent it somehow, don't ask how.... and replace the bearing too, that should straighten you right up..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •