Results 1 to 9 of 9
  1. #1
    RC Competitor
    Join Date
    Jun 2012
    Posts
    57

    Problem with Ez peak plus

    Just got a Ez peak plus 6amp charger today. I tried two different packs and when I went to set them up to charge they read connection break. Any ideas? I have one battery on the stock charger right now. The other was a brand new lipo fresh out the box.

  2. #2
    RC Champion
    Join Date
    Nov 2010
    Location
    United Kingdom of England land.
    Posts
    1,808
    connection break is a problem with the balance connection, either not plugged in fully, a balance wire has come loose somewhere probably in the housing area. Have a light pull on each baclance wire to see if a wire comes straight off. Soldering back on is tricky.
    Guide books aren't part of the packaging.

  3. #3
    RC Champion
    Join Date
    Nov 2011
    Location
    North Central OH
    Posts
    1,047
    Also remember to select 'balance' for your charge setting, not just charge.

    I have sucessfully re-soldered on a few broken balance wires, sometimes you need to remove some of the outside pack surround, those are some fragile little wires!

  4. #4
    RC Competitor
    Join Date
    Jun 2012
    Posts
    57
    I should have mentioned the first battery is a nimh battery and I still had the connection issue. Hopefully the charger itself isn't fried

  5. #5
    RC Competitor
    Join Date
    Jun 2012
    Posts
    57
    Tried everything again I'm pretty sure the charger is dead

  6. #6
    RC Champion
    Join Date
    Nov 2010
    Location
    United Kingdom of England land.
    Posts
    1,808
    check all the wires from the point that plugs in charger to where the battery plugs into the connector.
    Guide books aren't part of the packaging.

  7. #7
    RC Competitor
    Join Date
    Jun 2012
    Posts
    57
    Went to LHS they swapped just the Ez peak with no connectors and it all works perfectly must have been doa

  8. #8
    RC Champion
    Join Date
    Jan 2012
    Location
    muscoda, wi
    Posts
    1,245
    [QUOTE=kwitty;5227427]Also remember to select 'balance' for your charge setting, not just charge.

    even thou i mostly use lipo balance. i have used lipo charge. what is the difference. i still check the status +. and both cells charge accordingly. again i mostly use the lipo balance mode.
    I'm not krazy. My mother had me tested.

  9. #9
    RC Competitor
    Join Date
    Jun 2012
    Posts
    57
    [QUOTE=ajcar;5227690]
    Quote Originally Posted by kwitty View Post
    Also remember to select 'balance' for your charge setting, not just charge.

    even thou i mostly use lipo balance. i have used lipo charge. what is the difference. i still check the status +. and both cells charge accordingly. again i mostly use the lipo balance mode.
    Yes sir balance charging one new lipo as we type and I will charge another when it's done then my nihm after that haha this charger is going to get a work out today!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •