Results 1 to 15 of 15
  1. #1
    RC poster
    Join Date
    Jan 2012
    Posts
    14

    Exclamation Help! ESC smoking....Aahhh

    Driving the slash today, battery went dead so I started to change battery. Noticed the battery that it came with, the stock one was super hot and had melted the clear coating around it. The motor wasn't hot to the touch so I plugger in my lipo battery, as I did this just plugging it in and pushing the button to turn in, the battery cables got hot, the esc got hot and then it started smoking and I could smell something burning. I just unplugged my battery and it stopped. Please, if anybody has any ideas at all on what could be wrong I would really appreciate the help.

    Thanks

  2. #2
    RC Enthusiast
    Join Date
    Jun 2012
    Location
    Stoke on trent, United kingdom
    Posts
    40
    Sorry to be crude mate but thats a gone esc . Warranty ahoy !
    Slash 4x4 2650kv sirius(castle) mip's
    Summit

  3. #3
    RC poster
    Join Date
    Jan 2012
    Posts
    14
    Haha that's what I was thinking too. Any ideas on what might have happened to it?

  4. #4
    RC Qualifier
    Join Date
    Apr 2012
    Location
    Orlando,Florida
    Posts
    484
    You were probably using it for a while right? your supposed to check the temps every 15 mins keep that in mind.
    Rustler Vxl,Slash 2WD,Slash 4X4,SPC Lipos

  5. #5
    RC poster
    Join Date
    Jan 2012
    Posts
    14
    That's the thing, I only ran it for about 10-15 minutes before the battery died and then was super hot.

  6. #6
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Planet Vegeta
    Posts
    651
    maybe the truck was driven with too much load
    All I need now is to set a new lap record.

  7. #7
    RC Enthusiast
    Join Date
    Jun 2012
    Location
    Stoke on trent, United kingdom
    Posts
    40
    My electric's have been hopeless The esc always ran hot and the motor has detached the rotor from the magnet 4 times now .
    Slash 4x4 2650kv sirius(castle) mip's
    Summit

  8. #8
    RC Qualifier
    Join Date
    Aug 2011
    Location
    Columbia, SC
    Posts
    317
    Yeah the vxl's have heat issues, sticking buttons, and smoking. The velineons have issues with bearings and with the coming loose from the shaft. Running tekin, castle, and tenshock and not looking back.
    Traxxas gone bye bye!

  9. #9
    RC poster
    Join Date
    Jun 2012
    Posts
    6
    I just sent my velineon esc and motor in due to a glowing an smoking esc. Ran fine the day before, never over heated, plugged it in for the first run of the day the next day and it kind of surged while plugged in and smoke.

  10. #10
    RC Qualifier
    Join Date
    Apr 2012
    Posts
    310
    i wouldnt even waste my time sending it in to wait a month to get it back (took me 3 months from my hobby shop)..... just upgrade and save time and sht as sierra said upgrade and never ever look back!!!

  11. #11
    RC poster
    Join Date
    Jun 2012
    Posts
    6
    Quote Originally Posted by cmane419 View Post
    i wouldnt even waste my time sending it in to wait a month to get it back (took me 3 months from my hobby shop)..... just upgrade and save time and sht as sierra said upgrade and never ever look back!!!
    I'm in no rush to get it back. Bought a mamba max sct pro kit to hold me over

  12. #12
    RC poster
    Join Date
    Jun 2012
    Posts
    1
    I had the same problem, ESC was smoking(like BBQ) went to the shop in Belgium were I bought it( WWW.RCVULTURE.COM), the guy just take my ESC, and give me a new one in waranty.
    It all takes 5 min. The same with the motor of my brother in law(slash 4x4) in 5 min. the motor was swapped for a new one under warranty.
    That is called service of the dealer,

  13. #13
    RC Enthusiast
    Join Date
    Jul 2011
    Location
    Ontario, Canada
    Posts
    27
    Quote Originally Posted by full_throttle22 View Post
    Driving the slash today, battery went dead so I started to change battery. Noticed the battery that it came with, the stock one was super hot and had melted the clear coating around it. The motor wasn't hot to the touch so I plugger in my lipo battery, as I did this just plugging it in and pushing the button to turn in, the battery cables got hot, the esc got hot and then it started smoking and I could smell something burning. I just unplugged my battery and it stopped. Please, if anybody has any ideas at all on what could be wrong I would really appreciate the help.

    Thanks
    Same exact thing happened to me recently buddy! Only ran it for about 10 minutes on a beach, full throttle tho. Gonna upgrade to a mamba max pro with 3800kv motor, among some other minor upgrades. Got the system for $200 off ebay and waiting to recieve it now. I'm not sending the traxxas esc in but in your case, do the warranty!

  14. #14
    RC poster
    Join Date
    Jan 2012
    Posts
    14
    Quote Originally Posted by InceptorOne View Post
    Same exact thing happened to me recently buddy! Only ran it for about 10 minutes on a beach, full throttle tho. Gonna upgrade to a mamba max pro with 3800kv motor, among some other minor upgrades. Got the system for $200 off ebay and waiting to recieve it now. I'm not sending the traxxas esc in but in your case, do the warranty!
    Just spoke with traxxas. They said this is a common problem and they will send me a new ESC along with any other electrical parts that were destroyed (battery). So hopefully it won't take too long and I'll be back up and running soon.

    Do the different motors and ESC really make a big difference? I really like the waterproofing of the stock stuff though...

  15. #15
    RC Enthusiast
    Join Date
    Jul 2011
    Location
    Ontario, Canada
    Posts
    27
    Quote Originally Posted by full_throttle22 View Post
    Just spoke with traxxas. They said this is a common problem and they will send me a new ESC along with any other electrical parts that were destroyed (battery). So hopefully it won't take too long and I'll be back up and running soon.

    Do the different motors and ESC really make a big difference? I really like the waterproofing of the stock stuff though...
    They shipping you one for free or do you have to send yours in with the $50 form to fill out?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •