Results 1 to 7 of 7
  1. #1
    RC Competitor
    Join Date
    Jun 2012
    Location
    Long Island N.Y.
    Posts
    70

    TQI Slash 4X4 Sensors

    Has anyone mounted all the sensors on a Slash 4X4. I just purchased a Slash Ultimate and I can not seem to find all the pieces needed, even on the Traxxas site. Have these sensors and mounts even been out yet? Everywhere it shows out of stock or coming soon?

  2. #2
    RC Champion
    Join Date
    Nov 2010
    Location
    Lilydale, Victoria, Australia
    Posts
    2,845
    What cant you find ?

    Its all listed on the Traxxas website

    http://traxxas.com/products/models/e...h4x4-telemetry

    Cheers
    Slash Platinum
    Xerun 150 / Tenshock SC401 3500kv

  3. #3
    RC Competitor
    Join Date
    Jun 2012
    Location
    Long Island N.Y.
    Posts
    70
    Yes it is but not available anywhere. Also I see no documentation on installation anywhere

  4. #4
    RC Competitor
    Join Date
    Jun 2012
    Location
    Long Island N.Y.
    Posts
    70
    I just got an e mail from Traxxas. They state there is NO ETA available for these parts and no instructions exist at this time.
    Kind of misleading when you purchase a product and it shows the Traxxas link throughout the box and manual but you can't even buy the parts to make it work.

  5. #5
    RC Turnbuckle Jr. DiggerPede's Avatar
    Join Date
    Apr 2011
    Location
    Texas, Chemical Plant along the Gulf Coast
    Posts
    7,170
    I have the temp & voltage sensors installed and running. I'm waiting for the GPS module and expander to come available. Hopefully in the coming months.
    Weak Revenge
    Strong Forgive
    Intelligent Ignore

  6. #6
    RC Competitor
    Join Date
    Jun 2012
    Location
    Long Island N.Y.
    Posts
    70
    I just did it tonight. I bought a Slash Ultimate last week and I could not find the parts anywhere until today. First off I did not have to replace the motor mount, the speed sensor was able to screw right into it once you remove the screw and the little filler plate. You have to take the rear of the truck off the chassis so you can remove the differential. Once removed you remove the 3 existing screws that hold the spur gear to the diff. and screw on the magnet holder. The part I bought came with two of them and I used the larger one, make sure you slide the magnet in place before you screw it to the spur gear. The next sensor took care of temp. and voltage, it wraps around the motor. Once you take the cover off the reciever the slots are labeled. Plug in a battery and Holy smokes it works. The parts I used are as follows.
    6538 Telemetry Trigger Magnet Holder
    6520 Sensor RPM Long
    6521 Sensor Temp and Voltage.
    And that was it, all gauges on I Pod are working. Happy Motoring.

  7. #7
    RC Racer
    Join Date
    May 2012
    Location
    Bethlehem, PA
    Posts
    248
    Here is a post I created for the E-Revo - but it shares most of the same part #'s (just confirm) but the process to install is the same:

    http://traxxas.com/forums/showthread...e-amp-Voltage)

    Hope this helps!
    Mayor VXL
    ERevo|XO-1|Summit 1/8th

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •