Results 1 to 12 of 12
  1. #1
    RC Enthusiast
    Join Date
    Jun 2012
    Location
    Delaware
    Posts
    47

    Yet another lipo question

    So I upgraded to lipo today and have a question. I set up my onyx 235 to charge my new venom 5000mah 2s, 20c and according to the charger LCD it charged to about 2500 mah.... Is that expected with a new battery or did I do something wrong?

  2. #2
    RC Racer
    Join Date
    Apr 2012
    Location
    MA, USA
    Posts
    124
    i was about to post the same question about the lipo i just got
    Slash 4x4
    E-Maxx

  3. #3
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Philly area
    Posts
    507
    They come charged at a storage charge not empty. I think 3.5v or 3.8 ( cant remember exactly)already


    Sent from my iPhone using Tapatalk

  4. #4
    RC Racer
    Join Date
    Apr 2012
    Location
    MA, USA
    Posts
    124
    okay, i was thinking it was like my NiMh they take a full charge off the back.

    do you full charge lipos before you store them?
    Slash 4x4
    E-Maxx

  5. #5
    RC Champion
    Join Date
    Nov 2010
    Location
    Lilydale, Victoria, Australia
    Posts
    2,845
    Lipos should be stored at 3.85v / cell (50%) when not in use

    Cheers
    Slash Platinum
    Xerun 150 / Tenshock SC401 3500kv

  6. #6
    RC Qualifier
    Join Date
    Apr 2012
    Location
    Orlando,Florida
    Posts
    484
    on my lipo charger theres a setting that i set when the charger will cut off at, i charge my spc lipo at 5 amps and it cuts off at 6000 mah because its a 6000 mah lipo, so check your mah cutoff on your charger.
    Rustler Vxl,Slash 2WD,Slash 4X4,SPC Lipos

  7. #7
    RC Champion
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    1,249
    Quote Originally Posted by MadZoomer View Post
    So I upgraded to lipo today and have a question. I set up my onyx 235 to charge my new venom 5000mah 2s, 20c and according to the charger LCD it charged to about 2500 mah.... Is that expected with a new battery or did I do something wrong?
    perfectly normal, new batteries are sent in storage voltage

    Al
    MMM/2650, E-maxx Body=FUN !
    3 Slash 4x4
    Pede 4x4

  8. #8
    RC Enthusiast
    Join Date
    Jun 2012
    Location
    Delaware
    Posts
    47
    Thanks guys, after the first charge the battery is taking around 5100 mahs every time I charge it. What kind of runtime can I expect from it normally? It's a venom 2s 500 mah,20c. What do you guys usually get out of similar batteries?

  9. #9
    RC Champion
    Join Date
    Mar 2010
    Location
    Ontario, Canada
    Posts
    1,249
    35-50 min, bashing
    MMM/2650, E-maxx Body=FUN !
    3 Slash 4x4
    Pede 4x4

  10. #10
    Marshal Dadx2mj's Avatar
    Join Date
    Aug 2007
    Location
    So Cal
    Posts
    21,277
    You need to contact the vendor or manufacturer you got this equipment from Traxxas does not allow this type of tech support for other companies products on this forum.
    BlindMan Racing
    Rusty - MERV - Pede 4x4-Alias
    SPC Lipo Power

  11. #11
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,882
    For specific non-Traxxas battery and charger support, please contact the respective manufacturers.
    Alt-248 on the number pad =

  12. #12
    RC Enthusiast
    Join Date
    Jun 2012
    Location
    Delaware
    Posts
    47
    I apologize for my error. I didn't realize that I was asking for tech support for non traxxas products, just wanted to get input from experienced lipo users about what to expect from these batteries.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •