Results 1 to 10 of 10
  1. #1
    RC poster
    Join Date
    Feb 2012
    Posts
    13

    Ez Peak PLus won't change fully e-revo brushless batteries after time

    Hey guys what's up? I've had a problem when i tried to charged my nimh erbe batteries which were quite discharged. Yesterday I decided to charge them at 2.5A and to my surprise it charged more or less 200 mAh. I re charged them and it charged 500 mAh. Today i used my erbe believing it was fully charged and it run out of battery very fast. Instead of charging them at 2.5A, i charged at 1.2A but only 1000 mAh aproximately were charged. Any suggestion?

  2. #2
    RC Competitor
    Join Date
    Feb 2012
    Location
    England yorkshire
    Posts
    66
    what mah is your bat rated?

  3. #3
    RC Qualifier
    Join Date
    Mar 2012
    Location
    Central Florida
    Posts
    552
    Check your settings for the capacity cutoff. You can set it to cut off at a certain mah. Could be a possibility.
    ERBE, Sl4sh MT, P4de, 1/16 Grave Digger 4x4

  4. #4
    RC poster
    Join Date
    Feb 2012
    Posts
    13
    They are the stock 3000 mah nimh batteries

  5. #5
    RC poster
    Join Date
    Feb 2012
    Posts
    13
    I don't think that the cut off has been changed...

  6. #6
    RC Qualifier
    Join Date
    Aug 2011
    Location
    Virginia
    Posts
    826
    How old are the batteries?

    How long did they sit stored since the last usage?
    ERBE, Summit, Thunder Tiger MT4

  7. #7
    RC Turnbuckle Jr. O.G.'s Avatar
    Join Date
    Nov 2010
    Location
    South of St Louis
    Posts
    5,796
    It sounds like the battery developed a memory. The only thing to do is pitch it in the trash or try a discharge/charge cycle about 5 time to see if that helps.

    Sent from the cockpit of my Jeep Wrangler
    My Black & Blue Rally is faster than your color...

  8. #8
    RC Qualifier
    Join Date
    Nov 2011
    Location
    Planet Vegeta
    Posts
    651
    Quote Originally Posted by O.G. View Post
    It sounds like the battery developed a memory. The only thing to do is pitch it in the trash or try a discharge/charge cycle about 5 time to see if that helps.

    Sent from the cockpit of my Jeep Wrangler
    hmmm... rare for nimh to devolope one. i dont run all the power out of my nimh, yet no memory is made
    All I need now is to set a new lap record.

  9. #9
    Marshal ksb51rl's Avatar
    Join Date
    Nov 2006
    Location
    Northern NJ
    Posts
    15,151
    Sounds to me like a cell was damaged by running it too low. This would explain the early peaking. Another possible explanation is that the EPP charger might be messing up.
    Alt-241 on the number pad =

  10. #10
    RC poster
    Join Date
    Feb 2012
    Posts
    13
    They were stored like 2 months... the truck is quite new, i've bought it in january. Any idea?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •