Results 1 to 9 of 9
  1. #1
    RC Competitor
    Join Date
    Oct 2011
    Location
    Victoria, Australia
    Posts
    86

    EZ start smoking!

    ok so i just got a annsmann 7.2 volt batt for my starter, its 2000 mah though not 1500. but the guy said it just makes it last longer, i started it and it was fine landed on my roof from 1 meter and cut out. tried to start it again and the ez start wand got really hot and started to smoke. idk whats going on
    You don't need to plug Nitro into the wall

  2. #2
    RC Turnbuckle Jr. fallonguy's Avatar
    Join Date
    May 2006
    Location
    Dayton Nv.
    Posts
    3,181
    Does the engine turn over by hand? If it does then check the wires for a short then take the ez start motor off and check it to see if it turns over.
    Last edited by fallonguy; 06-11-2012 at 11:52 AM.
    I wanted to put a really cool signature but I ran

  3. #3
    RC Competitor
    Join Date
    Oct 2011
    Location
    Victoria, Australia
    Posts
    86
    yeah it turns over, my older battery turns it over fine and no smoking, but with the new batt it starts to smoke. i know the smart option would be to use my old batt but it is fried and doesnt work for long. so yeah basicly it starts it fine but the wand gets hot and smokes
    You don't need to plug Nitro into the wall

  4. #4
    RC Qualifier
    Join Date
    Jun 2012
    Location
    i don't know
    Posts
    551
    How long does it take for you to start your car?
    Cars: erevo vxl, 1/16 summit, stampede vxl, tmaxx

  5. #5
    RC Competitor
    Join Date
    Oct 2011
    Location
    Victoria, Australia
    Posts
    86
    when its cold it takes 40 seconds of priming and starting, when its hot i dunno anything from 5 to 15 seconds
    You don't need to plug Nitro into the wall

  6. #6
    RC Competitor
    Join Date
    Dec 2010
    Posts
    81
    I think your new bat has to much power and that's why it's smoking.

  7. #7
    RC Qualifier
    Join Date
    Jan 2012
    Location
    Olmsted Falls, Ohio
    Posts
    414
    was the old battery 7.2 volts?

  8. #8
    RC Competitor
    Join Date
    Oct 2011
    Location
    Victoria, Australia
    Posts
    86
    yeah the old battery was a 7.2v, 1500mah and the new one is 7.2v, 2000mah
    You don't need to plug Nitro into the wall

  9. #9
    RC Competitor
    Join Date
    Aug 2011
    Location
    Newfoundland, Canada
    Posts
    87
    Switch to a pull start.. That will fix it! : )

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •