Results 1 to 13 of 13

Hybrid View

  1. #1
    RC Enthusiast
    Join Date
    May 2012
    Posts
    42

    How to charge dead lipos.....sorry if this has been talked about already

    Hey Ya'll
    I have two 3cell 5000 lipos, they are both 'dead'. I have the EZ PEAK PLUS 6amp charger. I've read I can charge them for a short amount of time in NiMh mode just for a couple minutes to put a couple volts back in them, then fully charge them in lipo mode?? Has anyone done this, if so...PLEASE HELP!?

  2. #2
    RC Champion
    Join Date
    Jun 2006
    Location
    Stillwater, MN
    Posts
    1,610
    I've brought a few packs back from the dead using that method, just be extra careful.
    Revo.27TX/Jato.18/Maxx523/Maxx3.3/GMAXX/Rusty/ERBE

  3. #3
    RC Champion
    Join Date
    May 2011
    Location
    Biloxi, MS
    Posts
    1,547
    Make sure u watch it. There was a fella on here that burned his living rm up. Couldve been much worse. Use a lipo bag.
    Merv, Sl4sh, P4de, Embe, Slash
    2400/2200/4000kv

  4. #4
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,840
    from dead i would not mess with them, if they were like at 2.5v then it might work but dead all the way like 0.00v then they are dead like gone bye bye, need to get new lipos now.
    DEU 8:18 ESV

  5. #5
    RC Enthusiast
    Join Date
    May 2012
    Posts
    42
    Well I dont know how 'dead' they are. When plugged in the charger, it says low voltage

  6. #6
    RC Turnbuckle Jr. mike-susieq1's Avatar
    Join Date
    Nov 2010
    Location
    California
    Posts
    4,840
    are these traxxas lipos? use a multi meter to check them.
    DEU 8:18 ESV

  7. #7
    RC Champion
    Join Date
    Jul 2007
    Location
    Rc Room
    Posts
    1,484
    Quote Originally Posted by mike-susieq1 View Post
    are these traxxas lipos? use a multi meter to check them.
    I usually just read the label.

  8. #8
    RC Enthusiast
    Join Date
    May 2012
    Posts
    42
    Yes they are, I will check them this morning.

  9. #9
    RC Enthusiast
    Join Date
    May 2012
    Posts
    42
    One has 3 volts,,, the other, none. Now what? Does traxxas have a replacement policy.

  10. #10
    RC Turnbuckle Jr. vxlrocket's Avatar
    Join Date
    Dec 2007
    Location
    Manassas, Va
    Posts
    6,654
    Quote Originally Posted by mrproc1 View Post
    One has 3 volts,,, the other, none. Now what? Does traxxas have a replacement policy.
    if that's the case, it seems like you have a bad cell in the pack and charging in nimh mode could result in a bad fire. best bet is to soak the pack in saltwater and dispose of it properly.
    Associated rc8TE, rc8.2E, B4.2, Ofna LX2E, Slash

  11. #11
    RC Champion
    Join Date
    May 2011
    Location
    Central KS
    Posts
    1,071
    Quote Originally Posted by mrproc1 View Post
    One has 3 volts,,, the other, none. Now what? Does traxxas have a replacement policy.
    Call Traxxas support. Ask them if they have a replacement policy. You're saying one pack reads 9.0V (3.0V per cell?) and the other battery reads 0V? Perhaps the 9V one could be saved, but I'd probably still call Traxxas about both.
    What broke, uh, needs upgrading now?

  12. #12
    RC Qualifier
    Join Date
    Jun 2007
    Location
    Farmingville, NY
    Posts
    416
    Im in the same boat. I aquired 2 from my LHS that someone gave them.. one reading 8.46 volts the other 5v.

    Im going to try and charge the 8.46v pack outside on NIMH mode for a few minutes and see what happens.... Im more worried about the battery damaging the charger than anything... if it goes up in flames it will be a good show but please dont damage my beloved charger
    Traxxas please sell kits!

  13. #13
    RC poster
    Join Date
    Sep 2011
    Location
    Boston
    Posts
    14
    When i have a problem I charge my 3 cell lipo's as 2 Cell lipo's until they are done then change your charger to 3 cell 11.1 volts. This method has worked for me several times
    Quote Originally Posted by Racer83L View Post
    Im in the same boat. I aquired 2 from my LHS that someone gave them.. one reading 8.46 volts the other 5v.

    Im going to try and charge the 8.46v pack outside on NIMH mode for a few minutes and see what happens.... Im more worried about the battery damaging the charger than anything... if it goes up in flames it will be a good show but please dont damage my beloved charger

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •