Results 1 to 4 of 4
  1. #1
    RC poster
    Join Date
    May 2012
    Posts
    7

    need some help, power loss and fast red light

    ok, i sunk my boat about 4 days ago, i oild everything and let it dry out, now when i try to run it, it takes off fine but after about 5 sec, it drops to limp mode and i get a fast red blinking light on the receiver. iv searched but couldnt find what i was looking for.

  2. #2
    RC Champion
    Join Date
    Aug 2011
    Location
    El Cajon Ca
    Posts
    1,804
    The fast blinking red led on the receiver usually indicates an over temp issue, but the new version does not have the motor temp sensor. So I think you may have a defective receiver.... If you have another traxxas receiver from another truck/car you might try one to see if that helps.

    Check the motor bearings, strut, flexshaft etc for free movement.
    "enjoy your ride"

    Dennis

  3. #3
    RC poster
    Join Date
    May 2012
    Posts
    7
    ok....but it a bowl of rice for a day and everything is back to working. anyone have any good ideas on how to flush the water lines after a salt water run???

  4. #4
    RC Enthusiast
    Join Date
    Mar 2012
    Location
    North East ,England
    Posts
    36
    Get a sqeezy bottle or a bottle with a hand pump on and fill with clean water, then take off the silicone tubeing off your rudder put it on the end of your spout on your bottle and pump away.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •